summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbertaga2020-06-10 18:38:28 +0200
committerbertaga2020-06-10 18:38:28 +0200
commit4546ec65a9850b8bf925f563d779372376150d7a (patch)
tree54306f1d1098a4fbd185be8e9600cdcb7161f9eb
parent0457d47b3c699c632a1efb11213bcb12865e1534 (diff)
downloadaur-4546ec65a9850b8bf925f563d779372376150d7a.tar.gz
Fix .SRCINFO, change Maintainer info, change binaries' names
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3107fcb12657..ede7a5ad681f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = sipvicious
pkgdesc = SIPVicious is a set of tools that can be used to audit SIP VoIP systems.
pkgver = 0.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/EnableSecurity/sipvicious
- install = sipvicious.install
arch = any
license = GPL3
+ makedepends = python-setuptools
depends = python>=3.6
depends = python-scapy
source = sipvicious-0.3.0.tar.gz::https://github.com/EnableSecurity/sipvicious/archive/v0.3.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 4580e0107055..ceeb7c604e7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Xavier Devlamynck <magicrhesus@ouranos.be>
-# Cleanup: GI_Jack <iamjacksemail@hackermail.com>
+# Maintainer: Franck Stauffer <franck.stauffer@telecom-sudparis.eu>
+# Contributor: GI_Jack <iamjacksemail@hackermail.com>
+# Contributor: Xavier Devlamynck <magicrhesus@ouranos.be>
pkgname=sipvicious
pkgver=0.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="SIPVicious is a set of tools that can be used to audit SIP VoIP systems."
arch=('any')
url="https://github.com/EnableSecurity/sipvicious"
@@ -26,4 +27,8 @@ package() {
chmod +x setup.py
./setup.py install --root=$pkgdir
+
+ for _PROG in "${_PROGS[@]}"; do
+ mv $pkgdir/usr/bin/sipvicious_$_PROG $pkgdir/usr/bin/$_PROG
+ done
}