summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc-Olivier Barre2021-02-15 16:03:21 +0100
committerMarc-Olivier Barre2021-02-15 16:03:21 +0100
commit3f2c5fb28d5295e8d05895218912e904cd7b0970 (patch)
treef08a1e0d0c78e21e7a7e4bd910bbf9e429347748
parent688ab697caeea3c41df2229f9de725ea53811a12 (diff)
downloadaur-3f2c5fb28d5295e8d05895218912e904cd7b0970.tar.gz
Cleanup and bump to 0.99.8.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--glibc.patch84
3 files changed, 10 insertions, 91 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12453f831d04..e5d7f7f40cab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = siril
pkgdesc = An astronomical image processing software for Linux. (IRIS clone)
- pkgver = 0.99.6
- pkgrel = 5
+ pkgver = 0.99.8.1
+ pkgrel = 1
url = https://www.siril.org/
arch = i686
arch = x86_64
@@ -29,8 +29,8 @@ pkgbase = siril
optdepends = ffms2: films native support as image sequences and import
optdepends = libcurl-gnutls: check for updates
optdepends = gnuplot: photometry graphs creation
- source = https://free-astro.org/download/siril-0.99.6.tar.bz2
- sha1sums = 7a2689c6843e9c4bf97f225bb91a27600f543f79
+ source = https://free-astro.org/download/siril-0.99.8.1.tar.bz2
+ sha256sums = 45b73ee8d1e1bd7ff184478f90da59c729ca1bd5285fb2f7ac0237c6b5cdbdb2
pkgname = siril
diff --git a/PKGBUILD b/PKGBUILD
index 94423bbc366d..d2c1b40b9bbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Vincent Hourdin <vh|at|free-astro=DOT=vinvin.tf>
pkgname=siril
-pkgver=0.99.6
-pkgrel=5
+pkgver=0.99.8.1
+pkgrel=1
pkgdesc="An astronomical image processing software for Linux. (IRIS clone)"
arch=('i686' 'x86_64')
license=('GPLv3')
@@ -19,14 +19,17 @@ optdepends=('libpng: PNG import'
'gnuplot: photometry graphs creation')
source=("https://free-astro.org/download/siril-${pkgver}.tar.bz2")
-sha1sums=('7a2689c6843e9c4bf97f225bb91a27600f543f79')
+sha256sums=("45b73ee8d1e1bd7ff184478f90da59c729ca1bd5285fb2f7ac0237c6b5cdbdb2")
build() {
+ cd siril-${pkgver}
+ pwd
CFLAGS='-fcommon' ./autogen.sh --prefix=/usr
make
}
package() {
+ cd siril-${pkgver}
make DESTDIR="${pkgdir}" install
install -v -d ${pkgdir}/usr/share/applications/
install -v -d ${pkgdir}/usr/share/mime/packages/
diff --git a/glibc.patch b/glibc.patch
deleted file mode 100644
index f00a03ccdc4f..000000000000
--- a/glibc.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-Index: src/core/command.c
-===================================================================
---- src/core/command.c (revision 2434)
-+++ src/core/command.c (revision 2435)
-@@ -358,7 +358,7 @@
- norm = atof(word[2]);
- if (readfits(word[1], &fit, NULL))
- return -1;
-- fdiv(&gfit, &fit, norm);
-+ siril_fdiv(&gfit, &fit, norm);
- adjust_cutoff_from_updated_gfit();
- redraw(com.cvport, REMAP_ALL);
- redraw_previews();
-Index: src/core/proto.h
-===================================================================
---- src/core/proto.h (revision 2434)
-+++ src/core/proto.h (revision 2435)
-@@ -181,9 +181,8 @@
- int imoper(fits *a, fits *b, char oper);
- int sub_background(fits* image, fits* background, int layer);
- int addmax(fits *a, fits *b);
--int fdiv(fits *a, fits *b, float scalar);
--int ndiv(fits *a, fits *b);
--int fmul(fits *a, float coeff);
-+int siril_fdiv(fits *a, fits *b, float scalar);
-+int siril_ndiv(fits *a, fits *b);
- double gaussienne(double sigma, int size, double *gauss);
- int unsharp(fits *,double sigma, double mult, gboolean verbose);
- int crop(fits *fit, rectangle *bounds);
-Index: src/core/siril.c
-===================================================================
---- src/core/siril.c (revision 2434)
-+++ src/core/siril.c (revision 2435)
-@@ -260,8 +260,8 @@
- return 0;
- }
-
--/* If fdiv is ok, function returns 0. If overflow, fdiv returns 1*/
--int fdiv(fits *a, fits *b, float coef) {
-+/* If siril_fdiv is ok, function returns 0. If overflow, siril_fdiv returns 1*/
-+int siril_fdiv(fits *a, fits *b, float coef) {
- int i, layer;
- int retvalue = 0;
- double temp;
-@@ -289,7 +289,7 @@
-
- /* normalized division a/b, stored in a, with max value equal to the original
- * max value of a, for each layer. */
--int ndiv(fits *a, fits *b) {
-+int siril_ndiv(fits *a, fits *b) {
- double *div;
- int layer, i, nb_pixels;
- if (a->rx != b->rx || a->ry != b->ry || a->naxes[2] != b->naxes[2]) {
-@@ -489,7 +489,7 @@
- unsharp(&fit, sigma, 0, FALSE);
- soper(&fit, (double) level, OPER_ADD);
- nozero(&fit, 1);
-- fdiv(a, &fit, level);
-+ siril_fdiv(a, &fit, level);
- soper(a, (double) coeff, OPER_MUL);
- clearfits(&fit);
- invalidate_stats_from_fit(a);
-@@ -824,7 +824,7 @@
- }
-
- if (com.preprostatus & USE_FLAT) {
-- fdiv(brut, flat, level);
-+ siril_fdiv(brut, flat, level);
- }
-
- return 0;
-Index: src/gui/callbacks.c
-===================================================================
---- src/gui/callbacks.c (revision 2434)
-+++ src/gui/callbacks.c (revision 2435)
-@@ -4775,7 +4775,7 @@
- siril_log_message(_("Subtraction done ...\n"));
- break;
- case 1:
-- if (ndiv(&gfit, &background_fit)) {
-+ if (siril_ndiv(&gfit, &background_fit)) {
- set_cursor_waiting(FALSE);
- return;
- }