summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent2016-12-12 23:46:09 +0100
committerVincent2016-12-12 23:46:09 +0100
commitddcf0e91ec42b88b5cc5d5dc8c223ff664154144 (patch)
tree94a38f69483cf762a16613ac6ea6f52ba65d62c4
parent8895a8c9adb51339f6807222955c7533d29c5e33 (diff)
downloadaur-ddcf0e91ec42b88b5cc5d5dc8c223ff664154144.tar.gz
upstream release 0.9.5 and making opencv mandatory
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed8102efe6d4..76df30770ebc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = siril
pkgdesc = An astronomical image processing software for Linux. (IRIS clone)
- pkgver = 0.9.4
+ pkgver = 0.9.5
pkgrel = 1
url = https://free-astro.org/index.php/Siril
arch = i686
@@ -12,15 +12,15 @@ pkgbase = siril
depends = cfitsio
depends = gsl
depends = libconfig
+ depends = opencv
optdepends = libpng: PNG import
optdepends = libjpeg: JPEG import and export
optdepends = libtiff: TIFF import and export
optdepends = libraw: DSLR RAW images import
optdepends = giflib: animated GIF monochrome sequence export
optdepends = ffms2: films native support as image sequences and import
- optdepends = opencv: rotate and resize images
- source = https://free-astro.org/download/siril-0.9.4.tar.bz2
- sha1sums = bdcc3f43083a9a4a8071fbc5ed9b5d869e9d4517
+ source = https://free-astro.org/download/siril-0.9.5.tar.bz2
+ sha1sums = 3b5834c15d805ab485d5b1c9ceecb86ca9c074bc
pkgname = siril
diff --git a/PKGBUILD b/PKGBUILD
index 8c68de67e479..fbb567b44672 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Vincent Hourdin <vh|at|free-astro=DOT=vinvin.tf>
pkgname=siril
-pkgver=0.9.4
+pkgver=0.9.5
pkgrel=1
pkgdesc="An astronomical image processing software for Linux. (IRIS clone)"
arch=('i686' 'x86_64')
license=('GPLv3')
-depends=('gtk3' 'fftw' 'cfitsio' 'gsl' 'libconfig')
+depends=('gtk3' 'fftw' 'cfitsio' 'gsl' 'libconfig' 'opencv')
makedepends=('intltool')
url="https://free-astro.org/index.php/Siril"
optdepends=('libpng: PNG import'
@@ -14,13 +14,12 @@ optdepends=('libpng: PNG import'
'libraw: DSLR RAW images import'
'giflib: animated GIF monochrome sequence export'
'ffms2: films native support as image sequences and import'
-'opencv: rotate and resize images'
)
_pkgname="${pkgname}-${pkgver}"
source=("https://free-astro.org/download/${_pkgname}.tar.bz2")
-sha1sums=('bdcc3f43083a9a4a8071fbc5ed9b5d869e9d4517')
+sha1sums=('3b5834c15d805ab485d5b1c9ceecb86ca9c074bc')
build() {
cd "${_pkgname}"
@@ -33,7 +32,7 @@ package() {
make DESTDIR="${pkgdir}" install
install -v -d ${pkgdir}/usr/share/applications/
install -v -d ${pkgdir}/usr/share/mime/packages/
- install -v -m 644 platform-specific/linux/siril.desktop ${pkgdir}/usr/share/applications/
+ install -v -m 644 platform-specific/linux/org.free-astro.siril.desktop ${pkgdir}/usr/share/applications/
install -v -m 644 platform-specific/linux/siril.xml ${pkgdir}/usr/share/mime/packages/
}