summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMr.Smith19742023-07-02 19:01:34 +0300
committerMr.Smith19742023-07-02 19:01:34 +0300
commit98a792b4d346f61ec7e8a5f817ccf3fc59311eda (patch)
treec409856173e06cebdf6a04ddfbb82ff1744d622f
downloadaur-98a792b4d346f61ec7e8a5f817ccf3fc59311eda.tar.gz
Initial build
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD49
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..086b50ae7fe7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = siril
+ pkgdesc = An astronomical image processing software for Linux. (IRIS clone). Appimage version.
+ pkgver = 1.0.6
+ pkgrel = 1
+ url = https://www.siril.org/
+ arch = x86_64
+ license = GPL3
+ optdepends = libpng: PNG import
+ optdepends = libjpeg: JPEG import and export
+ optdepends = libtiff: TIFF import and export
+ optdepends = libraw: DSLR RAW images import
+ optdepends = ffms2: films native support as image sequences and import
+ optdepends = libcurl-gnutls: check for updates
+ optdepends = gnuplot: photometry graphs creation
+ options = !strip
+ source = Siril-1.0.6-x86_64.AppImage::https://free-astro.org/download/Siril-1.0.6-x86_64.AppImage
+ sha256sums = 2d97a05f250984bc27f7f38dacc518cd19c5dfbc55a1cd13a1f3792736dc3958
+
+pkgname = siril
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2800c8c91501
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+_pkgname=Siril
+_pkgver=1.0.6
+_appimage="${_pkgname}-${_pkgver}-x86_64.AppImage"
+_desktopfile="org.free_astro.siril.desktop"
+
+pkgname=siril
+pkgver='1.0.6'
+pkgrel=1
+pkgdesc="An astronomical image processing software for Linux. (IRIS clone). Appimage version."
+arch=('x86_64')
+license=('GPL3')
+makedepends=()
+options=(!strip)
+url="https://www.siril.org/"
+optdepends=('libpng: PNG import'
+ 'libjpeg: JPEG import and export'
+ 'libtiff: TIFF import and export'
+ 'libraw: DSLR RAW images import'
+ 'ffms2: films native support as image sequences and import'
+ 'libcurl-gnutls: check for updates'
+ 'gnuplot: photometry graphs creation')
+source=("${_appimage}::https://free-astro.org/download/${_appimage}")
+sha256sums=('2d97a05f250984bc27f7f38dacc518cd19c5dfbc55a1cd13a1f3792736dc3958')
+
+prepare() {
+ chmod +x ${_appimage}
+ ./${_appimage} --appimage-extract > /dev/null
+}
+
+build() {
+ # Fix permissions; .AppImage permissions are 700 for all directories
+ chmod -R a-x+rX squashfs-root/
+}
+
+package() {
+ # AppImage
+ install -Dm755 "${srcdir}/${_appimage}" "${pkgdir}/opt/${pkgname}/${pkgname}.AppImage"
+
+ # Desktop file
+ install -Dm644 "${srcdir}/squashfs-root/${_desktopfile}" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ # Icon images
+ install -dm755 "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 "${srcdir}/squashfs-root/org.free_astro.siril.svg" "${pkgdir}/usr/share/pixmaps/org.free_astro.siril.svg"
+
+ # Symlink executable
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -s "/opt/${pkgname}/${pkgname}.AppImage" "${pkgdir}/usr/bin/${pkgname}"
+}