summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2020-05-12 14:43:44 +0200
committerLubosz Sarnecki2020-05-12 14:54:10 +0200
commitaae587a09b8ff827b12797c55fb30d94532e367d (patch)
treebf726767d86778d05f7dec99ae9b3c698c86dd21
parentaf5c8e5cf0e9c9d812b58ee8dbea3e711ab9ee04 (diff)
downloadaur-aae587a09b8ff827b12797c55fb30d94532e367d.tar.gz
parse proper version.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce9ab7210a3f..3f07f5fb4cb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = siril-git
pkgdesc = An astronomical image processing software for Linux. (IRIS clone)
- pkgver = d1369ef5
+ pkgver = 0.9.12.2520.85ba0388
pkgrel = 1
url = https://free-astro.org/index.php/Siril
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 75b81e39c38b..1326c6ce65e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Vincent Hourdin <vh|at|free-astro=DOT=vinvin.tf>
pkgname=siril-git
_gitname=siril
-pkgver=d1369ef5
+pkgver=0.9.12.2520.85ba0388
pkgrel=1
pkgdesc="An astronomical image processing software for Linux. (IRIS clone)"
arch=('i686' 'x86_64')
@@ -21,7 +21,7 @@ sha1sums=('SKIP')
pkgver() {
cd "${srcdir}/${_gitname}"
- git log -1 --format="%h"
+ printf "%s.%s.%s" "$(git describe | cut -d "-" -f1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {