summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Abelli2021-11-01 20:03:52 -0400
committerCarlo Abelli2021-11-01 20:03:52 -0400
commitf75a3a17183fda7f9a706ed7f6110627b55607e8 (patch)
treed6814765c0abbbc3130a09f1631937f7fbb27604
downloadaur-f75a3a17183fda7f9a706ed7f6110627b55607e8.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..599e80bdf76e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = sirula
+ pkgdesc = An app launcher for wayland
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/DorianRudolph/sirula
+ arch = x86_64
+ license = GPL3
+ makedepends = cargo
+ depends = gtk-layer-shell
+ source = sirula-1.0.0.tar.gz::https://github.com/DorianRudolph/sirula/archive/refs/tags/v1.0.0.tar.gz
+ sha256sums = 311c2b3c1502a2e7c1c1ccd4c6a98f7fa387508cd2f3af23ea29b81f581292df
+
+pkgname = sirula
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02e77e843b29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Carlo Abelli <carlo@abelli.me>
+
+pkgname=sirula
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='An app launcher for wayland'
+url='https://github.com/DorianRudolph/sirula'
+arch=('x86_64')
+license=('GPL3')
+makedepends=('cargo')
+depends=('gtk-layer-shell')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/DorianRudolph/sirula/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('311c2b3c1502a2e7c1c1ccd4c6a98f7fa387508cd2f3af23ea29b81f581292df')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 -t "$pkgdir/usr/bin" "target/release/$pkgname"
+}