summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlotation2021-05-07 14:48:32 +0200
committerlotation2021-05-07 14:48:32 +0200
commit4ea2fced9ce0ade7beefe253588dbc56442ee853 (patch)
treeaacebba6b747394eefe6b1a64293713bc8566e83
downloadaur-4ea2fced9ce0ade7beefe253588dbc56442ee853.tar.gz
First Release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfe3c49ef24d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = sis
+ pkgdesc = Legacy Logic Synthesis Software
+ pkgver = 1.4
+ pkgrel = 1
+ url = https://github.com/JackHack96/logic-synthesis/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = readline
+ makedepends = gcc8
+ options = !strip
+ options = !emptydirs
+ source = https://github.com/JackHack96/logic-synthesis/archive/SIS.tar.gz
+ sha256sums = SKIP
+
+pkgname = sis
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a2789853070
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: lotation <xlapsiu@gmail.com>
+# Contributor: Matteo Iervasi <matteoiervasi@gmail.com>
+# Contributor: Joshua Chapman <john.chy99@gmail.com>
+
+pkgname=sis
+pkgver=1.4
+pkgrel=1
+pkgdesc="Legacy Logic Synthesis Software"
+arch=('i686' 'x86_64')
+url="https://github.com/JackHack96/logic-synthesis"
+license=('BSD')
+depends=('readline')
+makedepends=('gcc8')
+provides=($_pkgname)
+conflicts=($_pkgname)
+options=('!strip' '!emptydirs')
+source=("https://github.com/JackHack96/logic-synthesis/archive/SIS.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "logic-synthesis-SIS"
+
+ autoreconf -f -i
+ ./configure CXX=g++-8 CC=gcc-8 --prefix=/usr
+ make CXX=g++-8 CC=gcc-8
+}
+
+package() {
+ cd "logic-synthesis-SIS"
+
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+} \ No newline at end of file