summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Binet2021-10-05 16:23:42 -0400
committerGuillaume Binet2021-10-05 16:23:42 -0400
commit9f06002e0db59dc52a6fced6740b8aa6b08ec317 (patch)
tree63547fe2b70651c3618c1088a30b422d9988985a
parentb59e6a56cb7129a4ff6c4e610b445513736be9b4 (diff)
downloadaur-9f06002e0db59dc52a6fced6740b8aa6b08ec317.tar.gz
Adapted the tmux PKGBUILD to sixel-tmux.
Also ported the build to autoconf 2.71 while in there.
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
-rw-r--r--ac-271.patch131
3 files changed, 148 insertions, 14 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6c9b02962a98
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+sixel-tmux-git-8050_2.0.r3043.gbc340a30-1-x86_64.pkg.tar.zst
+sixel-tmux
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
index 4846f07eea89..d1c1c68ff701 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,11 @@
-# Maintainer: WorMzy Tykashi <wormzy.tykashi@gmail.com>
-# Contributor: Dmitry Korzhevin <dkorzhevin AT gmail DOT com>
-# Contributor: C.Coutinho <kikijump[at]gmail[dot]com>
-# Contributor: Grigorios Bouzakis <grbzks[at]gmail[dot]com>
-# Contributor: TDY <tdy@gmx.com>
+# Maintainer: Guillaume Binet <gbin@gootz.net>
-pkgname=tmux-git
-_gitname=tmux
-pkgver=8107_3.0a.r184.g745233d6
-pkgrel=2
-pkgdesc="A terminal multiplexer"
-url="https://github.com/tmux/tmux/wiki"
+pkgname=sixel-tmux-git
+_gitname=sixel-tmux
+pkgver=8050_2.0.r3043.gbc340a30
+pkgrel=1
+pkgdesc="A terminal multiplexer that display graphics one way or another!"
+url="https://github.com/csdvrx/sixel-tmux.git"
arch=('i686' 'x86_64')
license=('BSD')
depends=('ncurses' 'libevent')
@@ -18,10 +14,12 @@ optdepends=('libutempter: Record user sessions to utmp and wtmp files [add to de
#depends+=('libutempter') && _addconfigureflags="--enable-utempter"
provides=('tmux')
conflicts=('tmux')
-source=('git+https://github.com/tmux/tmux.git'
- 'LICENSE')
+source=('git+https://github.com/csdvrx/sixel-tmux.git'
+ 'LICENSE'
+ 'ac-271.patch')
md5sums=('SKIP'
- '71601bc37fa44e4395580b321963018e')
+ '71601bc37fa44e4395580b321963018e'
+ '6963a00dc940ec8c7f45e0770fa7e63e')
pkgver() {
cd ${_gitname}
@@ -33,6 +31,7 @@ pkgver() {
prepare() {
cd ${_gitname}
+ patch --forward --strip=1 --input="${srcdir}/ac-271.patch"
./autogen.sh
}
diff --git a/ac-271.patch b/ac-271.patch
new file mode 100644
index 000000000000..037728408190
--- /dev/null
+++ b/ac-271.patch
@@ -0,0 +1,131 @@
+diff --git a/Makefile.am b/Makefile.am
+index 7ac3d6ac..59ba9187 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -16,6 +16,9 @@ AM_CPPFLAGS += @XOPEN_DEFINES@ -DTMUX_CONF="\"$(sysconfdir)/tmux.conf\""
+ # Additional object files.
+ LDADD = $(LIBOBJS)
+
++# Add math for sixel
++AM_LDFLAGS = -lm
++
+ # Set flags for gcc.
+ if IS_GCC
+ AM_CFLAGS += -std=gnu99 -O2
+diff --git a/configure.ac b/configure.ac
+index 5fba1eaf..0712c265 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,7 +1,8 @@
+ # configure.ac
+
+-AC_INIT([tmux], next-3.1)
+-AC_PREREQ([2.60])
++AC_INIT([tmux],[next-3.1])
++AC_PREREQ([2.71])
++AC_CONFIG_FILES([Makefile])
+
+ AC_CONFIG_AUX_DIR(etc)
+ AC_CONFIG_LIBOBJ_DIR(compat)
+@@ -23,8 +24,6 @@ SAVED_LDFLAGS="$LDFLAGS"
+
+ # Set up the compiler in two different ways and say yes we may want to install.
+ AC_PROG_CC
+-AM_PROG_CC_C_O
+-AC_PROG_CC_C99
+ AC_PROG_CPP
+ AC_PROG_EGREP
+ AC_PROG_INSTALL
+@@ -39,14 +38,14 @@ test "$sysconfdir" = '${prefix}/etc' && sysconfdir=/etc
+ case "x$VERSION" in xnext*) enable_debug=yes;; esac
+ AC_ARG_ENABLE(
+ debug,
+- AC_HELP_STRING(--enable-debug, enable debug build flags),
++ AS_HELP_STRING(--enable-debug, enable debug build flags),
+ )
+ AM_CONDITIONAL(IS_DEBUG, test "x$enable_debug" = xyes)
+
+ # Is this a static build?
+ AC_ARG_ENABLE(
+ static,
+- AC_HELP_STRING(--enable-static, create a static build)
++ AS_HELP_STRING(--enable-static, create a static build)
+ )
+ if test "x$enable_static" = xyes; then
+ test "x$PKG_CONFIG" != x && PKG_CONFIG="$PKG_CONFIG --static"
+@@ -228,7 +227,7 @@ fi
+ # Look for utempter.
+ AC_ARG_ENABLE(
+ utempter,
+- AC_HELP_STRING(--enable-utempter, use utempter if it is installed)
++ AS_HELP_STRING(--enable-utempter, use utempter if it is installed)
+ )
+ if test "x$enable_utempter" = xyes; then
+ AC_CHECK_HEADER(utempter.h, enable_utempter=yes, enable_utempter=no)
+@@ -250,7 +249,7 @@ fi
+ # Look for utf8proc.
+ AC_ARG_ENABLE(
+ utf8proc,
+- AC_HELP_STRING(--enable-utf8proc, use utf8proc if it is installed)
++ AS_HELP_STRING(--enable-utf8proc, use utf8proc if it is installed)
+ )
+ if test "x$enable_utf8proc" = xyes; then
+ AC_CHECK_HEADER(utf8proc.h, enable_utf8proc=yes, enable_utf8proc=no)
+@@ -272,32 +271,24 @@ AM_CONDITIONAL(HAVE_UTF8PROC, [test "x$enable_utf8proc" = xyes])
+
+ # Check for b64_ntop. If we have b64_ntop, we assume b64_pton as well.
+ AC_MSG_CHECKING(for b64_ntop)
+-AC_TRY_LINK(
+- [
++AC_LINK_IFELSE([AC_LANG_PROGRAM([[
+ #include <sys/types.h>
+ #include <netinet/in.h>
+ #include <resolv.h>
+- ],
+- [b64_ntop(NULL, 0, NULL, 0);],
+- found_b64_ntop=yes,
+- found_b64_ntop=no
+-)
++ ]], [[b64_ntop(NULL, 0, NULL, 0);]])],[found_b64_ntop=yes],[found_b64_ntop=no
++])
+ if test "x$found_b64_ntop" = xno; then
+ AC_MSG_RESULT(no)
+
+ AC_MSG_CHECKING(for b64_ntop with -lresolv)
+ OLD_LIBS="$LIBS"
+ LIBS="$LIBS -lresolv"
+- AC_TRY_LINK(
+- [
++ AC_LINK_IFELSE([AC_LANG_PROGRAM([[
+ #include <sys/types.h>
+ #include <netinet/in.h>
+ #include <resolv.h>
+- ],
+- [b64_ntop(NULL, 0, NULL, 0);],
+- found_b64_ntop=yes,
+- found_b64_ntop=no
+- )
++ ]], [[b64_ntop(NULL, 0, NULL, 0);]])],[found_b64_ntop=yes],[found_b64_ntop=no
++ ])
+ if test "x$found_b64_ntop" = xno; then
+ LIBS="$OLD_LIBS"
+ AC_MSG_RESULT(no)
+@@ -652,4 +643,4 @@ AC_SUBST(AM_LDFLAGS)
+ LDFLAGS="$SAVED_LDFLAGS"
+
+ # autoconf should create a Makefile.
+-AC_OUTPUT(Makefile)
++AC_OUTPUT
+diff --git a/tmux.c b/tmux.c
+index 244e2d35..a26cb4d1 100644
+--- a/tmux.c
++++ b/tmux.c
+@@ -141,7 +141,7 @@ make_label(const char *label, char **cause)
+ #if __MSYS__ || __CYGWIN__ || _WIN32 || _WIN64
+ if (sb.st_uid != uid) {
+ #else
+- if (sb.st_uid != uid || (sb.st_mode & PERMS) != 0) {
++ if (sb.st_uid != uid || (sb.st_mode & ACCESSPERMS) != 0) {
+ #endif
+ errno = EACCES;
+ goto fail;