summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeomil722022-04-09 11:04:06 +0200
committerLeomil722022-04-09 11:04:06 +0200
commit8ce46324958ab15d3fe103e201976f8266194e0c (patch)
tree6628928fa7447e11d98a415975cba34d7548ae97
downloadaur-8ce46324958ab15d3fe103e201976f8266194e0c.tar.gz
release 1.19.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac6d17e717ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = sjasmplus
+ pkgdesc = SjASMplus is a Z80 cross-assembler
+ pkgver = 1.19.0
+ pkgrel = 1
+ url = https://github.com/z00m128/sjasmplus
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ depends = glibc
+ optdepends = lua: Lua scripting language
+ optdepends = tolua++: integrate C/C++ code with Lua
+ conflicts = sjasmplus
+ source = https://github.com/z00m128/sjasmplus/releases/download/v1.19.0/sjasmplus-1.19.0-src.tar.xz
+ sha256sums = 0d17e9a7f34811ca927803d6502e5620b32b14b13d4d8e782ade45cb2ef70c26
+
+pkgname = sjasmplus
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0d5a78048da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Leonardo Miliani <leonardo AT leonardomiliani DOT com>
+pkgname=sjasmplus
+pkgver=1.19.0
+pkgrel=1
+pkgdesc="SjASMplus is a Z80 cross-assembler"
+arch=(x86_64)
+url="https://github.com/z00m128/sjasmplus"
+license=(BSD)
+depends=(glibc)
+optdepends=('lua: Lua scripting language'
+ 'tolua++: integrate C/C++ code with Lua')
+conflicts=(sjasmplus)
+makedepends=(cmake)
+source=("https://github.com/z00m128/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver-src.tar.xz")
+
+sha256sums=('0d17e9a7f34811ca927803d6502e5620b32b14b13d4d8e782ade45cb2ef70c26')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../$pkgname-$pkgver \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd build
+ install -Dm755 sjasmplus "$pkgdir/usr/local/bin/$pkgname"
+}