summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2018-04-18 19:01:42 -0500
committerfrealgagu2018-04-18 19:01:42 -0500
commit504c0f8784b6691882a853c020170b877e038648 (patch)
tree9821f7d3558b03ef5ecfd2089699fb8e165701a0
downloadaur-504c0f8784b6691882a853c020170b877e038648.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e475b1ac7e8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = skaffold
+ pkgdesc = A command line tool that facilitates continuous development for Kubernetes applications
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/GoogleContainerTools/skaffold
+ arch = x86_64
+ license = APACHE
+ depends = docker
+ depends = kubectl-bin
+ optdepends = google-cloud-sdk: To use GKE
+ optdepends = minikube: To use Minikube
+ source = skaffold-0.4.0::https://storage.googleapis.com/skaffold/releases/v0.4.0/skaffold-linux-amd64
+ sha256sums = 8cbc63500f3501b72c7c88bafa94f2120aa05aedc1488e50cca68e33cb57338b
+
+pkgname = skaffold
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ea3c05a417ac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+skaffold-*.pkg.tar.xz
+skaffold-*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8aed31eaa95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
+
+pkgname=skaffold
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="A command line tool that facilitates continuous development for Kubernetes applications"
+arch=("x86_64")
+url="https://github.com/GoogleContainerTools/${pkgname}"
+license=("APACHE")
+depends=("docker" "kubectl-bin")
+optdepends=("google-cloud-sdk: To use GKE"
+ "minikube: To use Minikube")
+source=("${pkgname}-${pkgver}::https://storage.googleapis.com/${pkgname}/releases/v${pkgver}/${pkgname}-linux-amd64")
+sha256sums=("8cbc63500f3501b72c7c88bafa94f2120aa05aedc1488e50cca68e33cb57338b")
+
+package() {
+ install -Dm755 "${srcdir}/${pkgname}-${pkgver}" "${pkgdir}/usr/bin/${pkgname}"
+}