summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMazhar Hussain2023-01-13 16:22:45 +0500
committerMazhar Hussain2023-01-13 16:22:45 +0500
commit59141e113685c17866d5378868c8dbaedeb16183 (patch)
tree14bd1f6cf46be3145e52c34e5a52764ec938a07a
downloadaur-59141e113685c17866d5378868c8dbaedeb16183.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD28
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9cbcc62eb70b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = skeuowaita-git
+ pkgdesc = A skeuomorphic take on the Adwaita theme
+ pkgver = r78.83b953f
+ pkgrel = 1
+ url = https://github.com/Frostbitten-jello/Skeuowaita
+ arch = any
+ license = custom
+ depends = adwaita-icon-theme
+ provides = skeuowaita
+ conflicts = skeuowaita
+ source = skeuowaita-git::git+https://github.com/Frostbitten-jello/Skeuowaita
+ md5sums = SKIP
+
+pkgname = skeuowaita-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1aa416621b31
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+skeuowaita-git*
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f844f9fefa36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Mazhar Hussain <realmazharhussain@gmail.com>
+pkgname=skeuowaita-git
+pkgver=r78.83b953f
+pkgrel=1
+pkgdesc="A skeuomorphic take on the Adwaita theme"
+arch=(any)
+url="https://github.com/Frostbitten-jello/Skeuowaita"
+license=('custom')
+depends=(adwaita-icon-theme)
+provides=(skeuowaita)
+conflicts=(skeuowaita)
+source=("$pkgname"::"git+$url")
+md5sums=(SKIP)
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ echo r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ mkdir -p "$pkgdir"/usr/share/icons/Skeuowaita
+ mkdir -p "$pkgdir"/usr/share/licenses/"$pkgname"
+
+ cp -t "$pkgdir"/usr/share/icons/Skeuowaita/ -r index.theme scalable/ Extras/
+ cp -t "$pkgdir"/usr/share/licenses/"$pkgname"/ LICENSE.md
+}