summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2022-08-10 17:06:33 -0700
committerGI_Jack2022-08-10 17:06:33 -0700
commit042bd65d6b60b42a6045e114515d3bb9c1ff35fd (patch)
treef6aabfd88d9345841b85dd96c7cb109ac2a1c3ff
parentbdca044a834f4cdfc9eb235ade266e28e2581523 (diff)
downloadaur-042bd65d6b60b42a6045e114515d3bb9c1ff35fd.tar.gz
moved upstream to Kali Linux version
* still maintained - bugfixes * new identifiers * patched for new versions of OpenSSL set to upstream version 2.10b-2kali5
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 20 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a80ee79ed2f..ebe4a8f5f0ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,10 @@
+# Generated by mksrcinfo(replacement shim) v8
+# Wed Aug 10 05:04:40 PM PDT 2022
pkgbase = skipfish
pkgdesc = A fully automated, active web application security reconnaissance tool
- pkgver = 2.10b
- pkgrel = 2
- url = http://code.google.com/p/skipfish/
+ pkgver = 2.10b_2kali5
+ pkgrel = 1
+ url = https://gitlab.com/kalilinux/packages/skipfish
arch = any
license = APACHE
depends = openssl
@@ -10,10 +12,9 @@ pkgbase = skipfish
depends = zlib
depends = glibc
depends = sh
- source = https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/skipfish/skipfish-2.10b.tgz
+ source = https://gitlab.com/kalilinux/packages/skipfish/-/archive/kali/2.10b-2kali5/skipfish-kali-2.10b-2kali5.tar.gz
source = skipfish.patch
- sha256sums = 1a4fbc9d013f1f9b970946ea7228d943266127b7f4100c994ad26c82c5352a9e
+ sha256sums = f497d8bdce5f68c3ac13fb5144359145b777d55cc83262ad6ea8aafa9610a4e7
sha256sums = 096e9f7095a499605c8bf29bb9737397e9d5a168ec47888004dc8c2e7ceb0b62
pkgname = skipfish
-
diff --git a/PKGBUILD b/PKGBUILD
index b7cf5a4bf658..a9d5094fe2ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,34 @@
-# Maintainer: Christopher Loen <christopherloen at gmail dot com>
+# Maintainer: GI Jack <GI_Jack@hackermail.com>
+# Contributor: Christopher Loen <christopherloen at gmail dot com>
# Contributor: Sirat18 <aur@sirat18.de>
# Contributor: Alex Cartwright (alexc223@googlemail.com)
# Contributor: CRT <crt.011@gmail.com>
+
pkgname=skipfish
-pkgver=2.10b
-pkgrel=2
+pkgver=2.10b_2kali5
+_pkgver=2.10b-2kali5
+pkgrel=1
pkgdesc="A fully automated, active web application security reconnaissance tool"
arch=('any')
license=('APACHE')
-url='http://code.google.com/p/skipfish/'
+url='https://gitlab.com/kalilinux/packages/skipfish'
depends=('openssl' 'libidn' 'zlib' 'glibc' 'sh')
-source=("https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/skipfish/${pkgname}-${pkgver}.tgz"
+source=("https://gitlab.com/kalilinux/packages/skipfish/-/archive/kali/${_pkgver}/skipfish-kali-${_pkgver}.tar.gz"
"skipfish.patch")
-sha256sums=('1a4fbc9d013f1f9b970946ea7228d943266127b7f4100c994ad26c82c5352a9e'
+sha256sums=('f497d8bdce5f68c3ac13fb5144359145b777d55cc83262ad6ea8aafa9610a4e7'
'096e9f7095a499605c8bf29bb9737397e9d5a168ec47888004dc8c2e7ceb0b62')
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+build() {
+ cd "${srcdir}/${pkgname}-kali-${_pkgver}"
# Patch fixes application run directory system error
patch -Np0 -i ../skipfish.patch
+ patch -Np1 -i debian/patches/Fix-for-openssl-1.1.patch
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-kali-${_pkgver}"
install -dm755 "${pkgdir}/usr/share/${pkgname}"
install -dm755 "${pkgdir}/usr/share/${pkgname}/dictionaries"
cp -rf dictionaries/* "${pkgdir}/usr/share/${pkgname}/dictionaries/"