summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFinn Steglich2015-06-18 14:14:28 +0200
committerFinn Steglich2015-06-18 14:14:28 +0200
commitd29b72b73736133a82bd2b16502c38cde745c803 (patch)
tree875f6539e8b046239e9b7fde7df2c982fe4358de
downloadaur-d29b72b73736133a82bd2b16502c38cde745c803.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
-rw-r--r--skipfish.patch49
3 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ee7fea9324f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = skipfish
+ pkgdesc = A fully automated, active web application security reconnaissance tool
+ pkgver = 2.10b
+ pkgrel = 1
+ url = http://code.google.com/p/skipfish/
+ arch = any
+ license = APACHE
+ depends = openssl
+ depends = libidn
+ depends = zlib
+ depends = glibc
+ depends = sh
+ source = http://skipfish.googlecode.com/files/skipfish-2.10b.tgz
+ source = skipfish.patch
+ md5sums = 8edf6092f3d1835cb4a381b7a723db8a
+ md5sums = 640b24c2989f2316ac5e0926bba3b226
+
+pkgname = skipfish
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a45bdeb28f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Sirat18 <aur@sirat18.de>
+# Contributor: Alex Cartwright (alexc223@googlemail.com)
+# Contributor: CRT <crt.011@gmail.com>
+pkgname=skipfish
+pkgver=2.10b
+pkgrel=1
+pkgdesc="A fully automated, active web application security reconnaissance tool"
+arch=('any')
+license=('APACHE')
+url='http://code.google.com/p/skipfish/'
+depends=('openssl' 'libidn' 'zlib' 'glibc' 'sh')
+source=("http://skipfish.googlecode.com/files/${pkgname}-${pkgver}.tgz"
+ "skipfish.patch")
+
+md5sums=('8edf6092f3d1835cb4a381b7a723db8a'
+ '640b24c2989f2316ac5e0926bba3b226')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # Patch fixes application run directory system error
+ patch -Np0 -i ../skipfish.patch
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -d -Dm 0755 "${pkgdir}"/usr/share/"${pkgname}"
+ install -d -Dm 0755 "${pkgdir}"/usr/share/"${pkgname}"/dictionaries
+ install -Dm 0644 dictionaries/* "${pkgdir}"/usr/share/"${pkgname}"/dictionaries/
+ install -d -Dm 0755 assets "${pkgdir}"/usr/share/"${pkgname}"/assets
+ install -Dm 0644 assets/* "${pkgdir}"/usr/share/"${pkgname}"/assets/
+ install -d -Dm 0755 "${pkgdir}"/usr/share/"${pkgname}"/signatures
+ install -Dm 0644 signatures/* "${pkgdir}"/usr/share/"${pkgname}"/signatures/
+ install -d -Dm 0755 "${pkgdir}"/usr/bin
+ install -Dm 0755 skipfish tools/* "${pkgdir}"/usr/bin/
+ install -d -Dm 0755 "${pkgdir}"/usr/share/licenses/"${pkgname}"
+ install -Dm 0644 COPYING "${pkgdir}"/usr/share/licenses/"${pkgname}"/COPYING
+ install -Dm 0644 doc/skipfish.1 "${pkgdir}"/usr/share/man/man1/skipfish.1
+}
diff --git a/skipfish.patch b/skipfish.patch
new file mode 100644
index 000000000000..a889246771e0
--- /dev/null
+++ b/skipfish.patch
@@ -0,0 +1,49 @@
+--- src/config.h 2012-09-01 07:53:25.000000000 +0200
++++ src/config.h.new 2012-09-05 09:08:37.099387176 +0200
+@@ -35,10 +35,10 @@
+
+ /* Default paths to runtime files: */
+
+-#define ASSETS_DIR "assets"
++#define ASSETS_DIR "/usr/share/skipfish/assets"
+
+ /* Default signature file */
+-#define SIG_FILE "signatures/signatures.conf"
++#define SIG_FILE "/usr/share/skipfish/signatures/signatures.conf"
+
+ /* Various default settings for HTTP client (cmdline override): */
+
+
+--- signatures/signatures.conf 2012-09-01 07:53:25.000000000 +0200
++++ signatures/signatures.conf.new 2012-09-05 09:09:10.027968510 +0200
+@@ -6,23 +6,23 @@
+ # The mime signatures warn about server responses that have an interesting
+ # mime. For example anything that is presented as php-source will likely
+ # be interesting
+-include signatures/mime.sigs
++include /usr/share/skipfish/signatures/mime.sigs
+
+ # The files signature will use the content to determine if a response
+ # is an interesting file. For example, a SVN file.
+-include signatures/files.sigs
++include /usr/share/skipfish/signatures/files.sigs
+
+ # The messages signatures look for interesting server messages. Most
+ # are based on errors, such as caused by incorrect SQL queries or PHP
+ # execution failures.
+-include signatures/messages.sigs
++include /usr/share/skipfish/signatures/messages.sigs
+
+ # The apps signatures will help to find pages and applications who's
+ # functionality is a security risk by default. For example, phpinfo()
+ # pages that leak information or CMS admin interfaces.
+-include signatures/apps.sigs
++include /usr/share/skipfish/signatures/apps.sigs
+
+ # Context signatures are linked to injection tests. They look for strings
+ # that are relevant to the current injection test and help to highlight
+ # potential vulnerabilities.
+-include signatures/context.sigs
++include /usr/share/skipfish/signatures/context.sigs
+
+