summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-15 05:57:10 +0300
committerDimitris Kiziridis2020-05-15 05:57:10 +0300
commitef155bdb373bf41731c1e3e572d98b11ee3f2351 (patch)
tree6e559d5c58994c4615b5a2681f211f6a06f09467
parent5caf98fe275a266f4d9c44db7eaf67ec8b5d41f1 (diff)
downloadaur-ef155bdb373bf41731c1e3e572d98b11ee3f2351.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a7352ed06ca..ceb6e7e64d2c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,8 +6,10 @@ pkgbase = skm-bin
arch = x86_64
license = MIT
provides = skm
- source = https://github.com/TimothyYe/skm/releases/download/V0.8/skm-linux64-0.8.tar.gz
+ source = skm-bin-0.8.tar.gz::https://github.com/TimothyYe/skm/releases/download/V0.8/skm-linux64-0.8.tar.gz
+ source = LICENSE::https://github.com/TimothyYe/skm/raw/master/LICENSE
sha256sums = 7ede4eec2495dc346b412cd44baf8600cb84702c0623ef8dd9492bdb1cc34894
+ sha256sums = SKIP
pkgname = skm-bin
diff --git a/PKGBUILD b/PKGBUILD
index f235a8060a18..8082a8daf3c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,10 +8,14 @@ arch=('x86_64')
url='https://timothyye.github.io/skm'
license=('MIT')
provides=("${pkgname%-bin}")
-source=("https://github.com/TimothyYe/skm/releases/download/V${pkgver}/skm-linux64-${pkgver}.tar.gz")
-sha256sums=('7ede4eec2495dc346b412cd44baf8600cb84702c0623ef8dd9492bdb1cc34894')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/TimothyYe/skm/releases/download/V${pkgver}/skm-linux64-${pkgver}.tar.gz"
+ 'LICENSE::https://github.com/TimothyYe/skm/raw/master/LICENSE')
+sha256sums=('7ede4eec2495dc346b412cd44baf8600cb84702c0623ef8dd9492bdb1cc34894'
+ 'SKIP')
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}" \
"${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/LICENSE" -t \
+ "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file