summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam2021-06-18 00:19:01 -0700
committerSam2021-06-18 00:19:01 -0700
commit18a5a22642fdd6357f4d273d242ee24644021dda (patch)
tree89d8d9f7fb7183d697b4a661636b3a3cc5bfb9be
downloadaur-18a5a22642fdd6357f4d273d242ee24644021dda.tar.gz
Initial upload: skopeo-git 1.3.1_dev.r0.g2fee990a-1
feat(skopeo): :sparkles: Init with release 1.3.1_dev.r0.g2fee990a-1
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD47
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48cc9800921d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = skopeo-git
+ pkgdesc = A command line utility for various operations on container images and image repositories (git)
+ pkgver = 1.3.1_dev.r0.g2fee990a
+ pkgrel = 1
+ url = https://github.com/containers/skopeo.git
+ arch = any
+ license = Apache
+ makedepends = btrfs-progs
+ makedepends = go
+ makedepends = go-md2man
+ makedepends = git
+ makedepends = systemd
+ depends = containers-common
+ provides = skopeo
+ conflicts = skopeo
+ options = emptydirs
+ source = git+https://github.com/containers/skopeo.git
+ sha256sums = SKIP
+
+pkgname = skopeo-git
+ depends = containers-common
+ depends = libdevmapper.so
+ depends = libgpgme.so
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1a082b5ad898
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.*
+src
+pkg
+skopeo/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb0e1542a192
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: samarthj <dev@samarthj.com>
+
+pkgname=skopeo-git
+_pkgname=skopeo
+pkgver=1.3.1_dev.r0.g2fee990a
+pkgrel=1
+pkgdesc="A command line utility for various operations on container images and image repositories (git)"
+arch=('any')
+depends=(containers-common)
+makedepends=(btrfs-progs go go-md2man git systemd)
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+url="https://github.com/containers/$_pkgname.git"
+license=(Apache)
+options=('emptydirs')
+source=("git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname" || exit 1
+ commit=$(git rev-parse --short HEAD)
+ ver=$(grep const version/version.go | sed -re 's|.*"(.*)"$|\1|g')
+ echo "${ver//-/_}.r0.g${commit}"
+}
+
+build() {
+ export BUILDTAGS='seccomp apparmor'
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath"
+
+ cd $_pkgname || exit 1
+ make EXTRA_LDFLAGS='-s -w -linkmode=external'
+}
+
+package() {
+ depends+=('libdevmapper.so' 'libgpgme.so')
+
+ cd $_pkgname || exit 1
+ make install DESTDIR="$pkgdir" PREFIX="$pkgdir"/usr
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # remove man pages provided by containers-common
+ rm -rvf "${pkgdir}/usr/share/man/man5"
+ rm -rvf "${pkgdir}/etc"
+}