summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrés J. Díaz2018-05-11 17:59:32 +0200
committerAndrés J. Díaz2018-05-11 17:59:32 +0200
commit7b88b37aa67023fe39bbaf1440999035a50c60ec (patch)
tree180d46735e85fb7951e0e2080ed67348a2e6ecef
parente554e3f317635e406cd3e00b2f8cc4da8e8175ec (diff)
downloadaur-sks.tar.gz
Force the proper version of ocaml to compile sks properly
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6c16f382d7..9723c95b575 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = sks
pkgdesc = Synchronizing OpenPGP Key Server
pkgver = 1.1.6
- pkgrel = 3
+ pkgrel = 4
url = https://bitbucket.org/skskeyserver/sks-keyserver/
install = sks.install
arch = i686
arch = x86_64
license = GPL
- makedepends = ocaml
- makedepends = db
- makedepends = camlp4
+ makedepends = ocaml<4.06
+ makedepends = db<5.4
+ makedepends = camlp4<4.06
backup = etc/sks/sksconf
backup = etc/sks/forward.exim
backup = etc/sks/forward.postfix
diff --git a/PKGBUILD b/PKGBUILD
index 461fff39b93..f8d1440f9ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
pkgname=sks
pkgver=1.1.6
-pkgrel=3
+pkgrel=4
arch=('i686' 'x86_64')
license=('GPL')
pkgdesc='Synchronizing OpenPGP Key Server'
-makedepends=('ocaml' 'db' 'camlp4')
+makedepends=('ocaml<4.06' 'db<5.4' 'camlp4<4.06')
url='https://bitbucket.org/skskeyserver/sks-keyserver/'
install='sks.install'
backup=('etc/sks/sksconf'