summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin Lloyd2015-06-09 17:22:00 -0700
committerGavin Lloyd2015-06-09 17:22:00 -0700
commit89dfca84fb0f8db13d6e9b29897f86758843e58f (patch)
treec044d82f2decb94fd4bed8b79978a341dc940594
downloadaur-89dfca84fb0f8db13d6e9b29897f86758843e58f.tar.gz
Init commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05d1c4aad760
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = skul-git
+ pkgdesc = Create, format and mount loopback-based, encrypted LUKS containers
+ pkgver = 0.28.8e58846
+ pkgrel = 1
+ url = https://github.com/gavinhungry/skul
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = cryptsetup
+ depends = e2fsprogs
+ depends = udisks
+ source = skul-git::git+https://github.com/gavinhungry/skul.git#branch=master
+ md5sums = SKIP
+
+pkgname = skul-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f9fefa6c7b86
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
+
+pkgname=skul-git
+pkgver=0.28.8e58846
+pkgrel=1
+pkgdesc="Create, format and mount loopback-based, encrypted LUKS containers"
+url="https://github.com/gavinhungry/skul"
+license="MIT"
+arch=('any')
+makedepends=('git')
+depends=('cryptsetup' 'e2fsprogs' 'udisks')
+source=("${pkgname}::git+${url}.git#branch=master")
+md5sums=('SKIP')
+
+pkgver () {
+ cd "${srcdir}/${pkgname}"
+ echo "0.$(git rev-list --count HEAD).$(git describe --always | sed 's|-|.|g')"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ git submodule init
+ git submodule update
+
+ mkdir -p ${pkgdir}/usr/bin
+
+ install -m 755 abash/abash.sh ${pkgdir}/usr/bin/skul
+ echo >> ${pkgdir}/usr/bin/skul
+ cat skul.sh >> ${pkgdir}/usr/bin/skul
+}