summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:30:56 +0200
committerM0Rf302015-06-17 16:30:56 +0200
commit7ce72c6d3a66769c4e37485827f2c7c0450ce45c (patch)
tree439033fc8611ff96db0d3462beba79220c2e9387
downloadaur-7ce72c6d3a66769c4e37485827f2c7c0450ce45c.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD75
-rw-r--r--skulltag.install4
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..365bf496730c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = skulltag
+ pkgdesc = Closed source OpenGL ZDoom port with Client/Server multiplayer.
+ pkgver = 098d
+ pkgrel = 4
+ url = http://skulltag.net/
+ install = skulltag.install
+ arch = i686
+ arch = x86_64
+ license = closed
+ depends = sdl
+ depends = gtk2
+ depends = libjpeg6
+ optdepends = timidity++: midi support
+ optdepends = freedoom: free IWAD
+
+pkgname = skulltag
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e996a2cbb794
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,75 @@
+# Maintainer: M0Rf30
+# Contributor: Mikael Eriksson <mikael_eriksson@miffe.org>
+# Original PKGBUILD by Sean Streeter <anubis2591 at gmail dot com>
+pkgname=skulltag
+pkgver=098d
+pkgrel=4
+pkgdesc="Closed source OpenGL ZDoom port with Client/Server multiplayer."
+arch=('i686' 'x86_64')
+url="http://skulltag.net/"
+license=('closed')
+depends=('sdl' 'gtk2' 'libjpeg6')
+optdepends=('timidity++: midi support'
+ 'freedoom: free IWAD')
+install=skulltag.install
+
+case "$CARCH" in
+ i686)
+ source=("http://skulltag.com/download/files/release/st-v${pkgver}_linux-base.tar.bz2"
+ "http://skulltag.com/download/files/release/st-v${pkgver}_linux-x86.tar.bz2"
+ "http://www.fmod.org/download/fmodex/api/Linux/fmodapi42416linux.tar.gz")
+ md5sums=('afe482e04ce3f51c94915e07c3aff3b0'
+ 'faa005fc5b44da424d87d6a17eaafccb'
+ '00b157e8d09d539b0a7023c48b71422a')
+ ;;
+ x86_64)
+ source=("http://skulltag.com/download/files/release/st-v${pkgver}_linux-base.tar.bz2"
+ "http://skulltag.com/download/files/release/st-v${pkgver}_linux-x86_64.tar.bz2"
+ "http://www.fmod.org/download/fmodex/api/Linux/fmodapi42416linux64.tar.gz")
+ depends=(${depends[@]} libpng12)
+ md5sums=('afe482e04ce3f51c94915e07c3aff3b0'
+ '46e677cc851698ac101d42b6140b6047'
+ '70b2a6a2618ee9823ab564b4e945c885')
+ ;;
+esac
+
+package() {
+ cd $srcdir
+
+cat > skulltag.sh << EOF
+#!/bin/sh
+export LD_LIBRARY_PATH=/usr/share/skulltag/lib
+exec /usr/share/skulltag/skulltag "\$@"
+EOF
+
+cat > skulltag-server.sh << EOF
+#!/bin/sh
+export LD_LIBRARY_PATH=/usr/share/skulltag/lib
+exec /usr/share/skulltag/skulltag-server "\$@"
+EOF
+
+ install -Dm644 "announcer/Skulltag_98a_announcer.pk3" "$pkgdir/usr/share/skulltag/announcer/Skulltag_98a_announcer.pk3"
+ for fn in skins/*; do
+ install -Dm644 "$fn" "$pkgdir/usr/share/skulltag/$fn"
+ done
+ install -Dm644 "Skulltag Version History.txt" "$pkgdir/usr/share/skulltag/Skulltag Version History.txt"
+ install -Dm644 "skulltag_data.pk3" "$pkgdir/usr/share/skulltag/skulltag_data.pk3"
+ install -Dm644 "skulltag.pk3" "$pkgdir/usr/share/skulltag/skulltag.pk3"
+ install -Dm755 "liboutput_sdl.so" "$pkgdir/usr/share/skulltag/lib/liboutput_sdl.so"
+ install -Dm755 "libsnes_spc.so" "$pkgdir/usr/share/skulltag/lib/libsnes_spc.so"
+ install -Dm755 "skulltag" "$pkgdir/usr/share/skulltag/skulltag"
+ install -Dm755 "skulltag-server" "$pkgdir/usr/share/skulltag/skulltag-server"
+ install -Dm755 "skulltag.sh" "$pkgdir/usr/bin/skulltag"
+ install -Dm755 "skulltag-server.sh" "$pkgdir/usr/bin/skulltag-server"
+
+ case "$CARCH" in
+ i686)
+ install -Dm755 "fmodapi42416linux/api/lib/libfmodex-4.24.16.so" "$pkgdir/usr/share/skulltag/lib/libfmodex-4.24.16.so"
+ ;;
+ x86_64)
+ install -Dm755 "fmodapi42416linux64/api/lib/libfmodex64-4.24.16.so" "$pkgdir/usr/share/skulltag/lib/libfmodex64-4.24.16.so"
+ ;;
+ esac
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/skulltag.install b/skulltag.install
new file mode 100644
index 000000000000..36c6129781c0
--- /dev/null
+++ b/skulltag.install
@@ -0,0 +1,4 @@
+## arg 1: the new package version
+post_install() {
+ echo ":: Skulltag looks for IWADs (e.g. doom2.wad) in CWD, ~/.skulltag and /usr/local/share"
+}