summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTEL.RED2015-06-09 06:00:32 +0300
committerTEL.RED2015-06-09 06:00:32 +0300
commit7450d2144e2d67034542ec1f344e9a01f70c6c47 (patch)
treeb08781d609327bc69d8bed79415c46347f70d31d
downloadaur-7450d2144e2d67034542ec1f344e9a01f70c6c47.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD63
-rw-r--r--sky.install15
4 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f067c8d6fce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = sky
+ pkgdesc = Lync & Skype for business on Linux
+ pkgver = 2.0.352
+ pkgrel = 1
+ url = http://tel.red
+ install = sky.install
+ arch = x86_64
+ license = custom: Copyright © 2015 TEL.RED LLC
+ makedepends = binutils
+ makedepends = chrpath
+ depends = openssl
+ depends = nss
+ depends = gstreamer0.10-base
+ depends = libpulse
+ depends = alsa-lib
+ depends = v4l-utils
+ depends = libxinerama
+ depends = libxss
+ depends = libxcb
+ optdepends = ibus: Intelligent Input Bus (IBus) support
+ options = !strip
+ source_x86_64 = http://tel.red/linux/sky_ubuntu64_v2.0.352.deb
+ sha256sums_x86_64 = 4a716713f3d836a59ba8e7411200a7b9d884812e73ced2ee8fe54b00a35a6867
+
+pkgname = sky
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..38d3327a51e4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.deb
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5dbecd2614e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: TEL.RED LLC <ask_at_tel_dt_red>
+# Contributor: Jameson Pugh <imntreal@gmail.com>
+# Contributor: stef312 <stef312_at_gmail_dot_com>
+# Contributor: Gaspar de Elías <caspercba_at_hotmail_dot_com>
+# Contributor: Artem Sheremet <dot_doom_at_gmail_dot_com>
+
+pkgname=sky
+pkgver=2.0.352
+pkgrel=1
+pkgdesc="Lync & Skype for business on Linux"
+
+arch=(
+ 'x86_64'
+# 'i686'
+)
+if [[ $CARCH == 'x86_64' ]]; then
+ _arch=64
+elif [[ $CARCH == 'i686' ]]; then
+ _arch=32
+fi
+
+url="http://tel.red"
+
+license=('custom: Copyright © 2015 TEL.RED LLC')
+options=('!strip')
+install="${pkgname}.install"
+
+depends=('openssl' 'nss' 'gstreamer0.10-base' 'libpulse' 'alsa-lib' 'v4l-utils'
+ 'libxinerama' 'libxss' 'libxcb')
+optdepends=('ibus: Intelligent Input Bus (IBus) support')
+makedepends=('binutils' 'chrpath')
+
+source_x86_64=("http://tel.red/linux/sky_ubuntu64_v${pkgver}.deb")
+# source_i686=("http://tel.red/linux/sky_ubuntu32_v${pkgver}.deb")
+
+sha256sums_x86_64=('4a716713f3d836a59ba8e7411200a7b9d884812e73ced2ee8fe54b00a35a6867')
+# sha256sums_i686=('c7e08416db58b0861dc9727c08aa1398fee68611bf60e00ea9d7606cbf4d0d38')
+
+package() {
+ cd "${srcdir}"
+ ar x "sky_ubuntu${_arch}_v${pkgver}.deb" >/dev/null
+ tar -zxf data.tar.gz
+
+ local icu_libs
+ icu_libs="libicudata libicudata libicudata libicule libiculx libicutest
+ libicutu libicuuc libicui18n libicuio"
+
+ # fix broken rpaths of bundled icu libs
+ for lib in ${icu_libs}; do
+ chrpath -d "${srcdir}"/opt/sky_linux/lib/${lib}.so*
+ done
+
+ cp -rf "${srcdir}/etc" "${pkgdir}/"
+ install -Dm 644 "${srcdir}/usr/share/applications/sky.desktop" "${pkgdir}/usr/share/applications/sky.desktop"
+ install -Dm 644 "${srcdir}/usr/share/pixmaps/sky.png" "${pkgdir}/usr/share/pixmaps/sky.png"
+ mv "${srcdir}/opt" "${pkgdir}/"
+ find "${pkgdir}/" -type d -exec chmod 0755 {} \;
+
+ mkdir -m 755 "${pkgdir}/usr/bin"
+ ln -sr "${pkgdir}/opt/sky_linux/sky.sh" "${pkgdir}/usr/bin/sky"
+}
+
+# vim: set ts=2 sw=2 ft=sh noet:
diff --git a/sky.install b/sky.install
new file mode 100644
index 000000000000..5fe416e614a1
--- /dev/null
+++ b/sky.install
@@ -0,0 +1,15 @@
+post_install() {
+ if [[ -x usr/bin/xdg-icon-resource ]]; then
+ usr/bin/xdg-icon-resource forceupdate &>/dev/null || true
+ fi
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+