summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoses Narrow2020-02-19 16:53:10 -0600
committerMoses Narrow2020-02-19 16:53:10 -0600
commit4a8523e61bfdbf394183bb31ad69f88d35d41359 (patch)
tree2e1a8bf5338cbc4531bcf928c7b3c45a41429d6b
parent4d255e8decf79464b7672b0bd3fb4bebc94d7b2e (diff)
downloadaur-skycoin-hardware-wallet-daemon.tar.gz
update dependancies and signature checking
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD33
-rw-r--r--PKGBUILD.sigbin566 -> 566 bytes
3 files changed, 24 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c362cd6f63ba..7fc079401f8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = skycoin-hardware-wallet-daemon
pkgdesc = HTTP API to interface with the wallets supported by Skycoin
pkgver = autogenerated
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/SkycoinProject/hardware-wallet-daemon
arch = any
- makedepends = dep
makedepends = git
makedepends = go
- makedepends = gcc
+ makedepends = skycoin-keyring
source = git+https://github.com/SkycoinProject/hardware-wallet-daemon.git#branch=master
- source = https://raw.githubusercontent.com/0pcom/skycoin_archlinux_packages/master/key
+ source = PKGBUILD.sig
+ validpgpkeys = DE08F924EEE93832DABC642CA8DC761B1C0C0CFC
+ validpgpkeys = 98F934F04F9334B81DFA3398913BBD5206B19620
+ sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 41c0a4a42ae64479b008392053f4a947618acd6bb9c3ed2672dafdb2453caa14
pkgname = skycoin-hardware-wallet-daemon
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index f427cb1bcc8b..99695722fd73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,15 +7,18 @@ githuborg=SkycoinProject
pkgdesc="HTTP API to interface with the wallets supported by Skycoin"
pkgver='autogenerated'
pkggopath="github.com/${githuborg}/${pkgname1}"
-pkgrel=1
+pkgrel=2
arch=('any')
url="https://${pkggopath}"
license=()
-makedepends=(dep git go gcc)
+makedepends=(git go skycoin-keyring)
source=("git+${url}.git#branch=${BRANCH:-master}"
-"https://raw.githubusercontent.com/0pcom/skycoin_archlinux_packages/master/key")
+"PKGBUILD.sig")
sha256sums=('SKIP'
-'41c0a4a42ae64479b008392053f4a947618acd6bb9c3ed2672dafdb2453caa14')
+'SKIP')
+validpgpkeys=('DE08F924EEE93832DABC642CA8DC761B1C0C0CFC' # Moses Narrow <moe_narrow@use.startmail.com>
+ '98F934F04F9334B81DFA3398913BBD5206B19620') #iketheadore skycoin <luxairlake@protonmail.com>
+
case "$CARCH" in
x86) export GOARCH="386" GO386="387" ;;
@@ -42,9 +45,8 @@ mipsel) export GOARCH="mipsle" ;;
}
prepare() {
- gpg --import key
#verify PKGBUILD signature
- gpg --verify ../PKGBUILD.sig ../PKGBUILD
+ gpg --verify ${srcdir}/PKGBUILD.sig ../PKGBUILD
# https://wiki.archlinux.org/index.php/Go_package_guidelines
mkdir -p ${srcdir}/go/src/github.com/${projectname}/ ${srcdir}/go/bin
ln -rTsf ${srcdir}/${pkgname1} ${srcdir}/go/src/github.com/${projectname}/${pkgname1}
@@ -59,15 +61,17 @@ build() {
export GOPATH="${srcdir}"/go
export GOBIN=${GOPATH}/bin
export PATH=${GOPATH}/bin:${PATH}
- cd ${srcdir}/go/src/github.com/${projectname}/${pkgname1}/cmd
- go install \
- -gcflags "all=-trimpath=${GOPATH}" \
- -asmflags "all=-trimpath=${GOPATH}" \
- -v ./...
-
- cd ${srcdir}/go/bin
+ cmddir=${srcdir}/go/src/github.com/${githuborg}/${pkgname1}/cmd
+ #using go build for determinism
+ cd ${cmddir}/daemon
+ msg2 'building skywire-hw-daemon binary'
+ go build -trimpath -ldflags '-extldflags ${LDFLAGS}' -ldflags=-buildid= -o $GOBIN/ .
+ #binary transparency
+ cd $GOBIN
mv daemon skycoin-hw-daemon
-}
+ msg2 'binary sha256sums'
+ sha256sum $(ls)
+ }
package() {
options=(!strip staticlibs)
@@ -75,7 +79,6 @@ package() {
mkdir -p ${pkgdir}/usr/bin
mkdir -p ${pkgdir}/usr/lib/${projectname}/go/bin
#install binaries & symlink to /usr/bin
- msg2 'installing binaries'
skybin="${srcdir}"/go/bin
#collect the binaries & install
skybins=$( ls "$skybin")
diff --git a/PKGBUILD.sig b/PKGBUILD.sig
index 4c0d7a9b7ddf..373f22bfda4f 100644
--- a/PKGBUILD.sig
+++ b/PKGBUILD.sig
Binary files differ