summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2019-10-28 16:52:19 +0700
committerKonstantin Shalygin2019-10-28 16:52:19 +0700
commitfacead77d7f95f870ab539ba83c51c080540db7d (patch)
treee257d52d0589c3dc69245e698612eda44b70d695
downloadaur-facead77d7f95f870ab539ba83c51c080540db7d.tar.gz
First AUR release
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD44
-rw-r--r--skydive.sysusers1
-rw-r--r--skydive.tmpfiles1
5 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edf019290c07
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = skydive
+ pkgdesc = Real-time network topology and protocols analyzer
+ pkgver = 0.25.0
+ pkgrel = 1
+ url = https://skydive.network
+ arch = x86_64
+ arch = i686
+ license = Apache
+ makedepends = go
+ makedepends = libpcap
+ makedepends = libxml2
+ makedepends = protobuf
+ makedepends = libvirt
+ makedepends = npm
+ options = !buildflags
+ source = https://github.com/skydive-project/skydive/archive/v0.25.0.tar.gz
+ source = skydive.tmpfiles
+ source = skydive.sysusers
+ sha256sums = 698413e4c9c5dbd5977328bd46e912cd760b500dacf6ec4f4c453f6a494c09ec
+ sha256sums = 5d3b4f628a485363ec47897054b2d4a84ef680b9db93562a58e42971f5597bc3
+ sha256sums = acbccbc4dace958b4d7eeeb3879e6f80fe798ffb5e7be5375008970f6ee30c34
+
+pkgname = skydive
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7c6927b4669a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/*
+src/*
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18eba5804b5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Shalygin Konstantin <k0ste@k0ste.ru>
+# Contributor: Shalygin Konstantin <k0ste@k0ste.ru>
+
+pkgname='skydive'
+pkgver='0.25.0'
+pkgrel='1'
+pkgdesc='Real-time network topology and protocols analyzer'
+arch=('x86_64' 'i686')
+url="https://${pkgname}.network"
+license=('Apache')
+makedepends=('go' 'libpcap' 'libxml2' 'protobuf' 'libvirt' 'npm')
+source=("https://github.com/${pkgname}-project/${pkgname}/archive/v${pkgver}.tar.gz"
+ "${pkgname}.tmpfiles"
+ "${pkgname}.sysusers")
+sha256sums=('698413e4c9c5dbd5977328bd46e912cd760b500dacf6ec4f4c453f6a494c09ec'
+ '5d3b4f628a485363ec47897054b2d4a84ef680b9db93562a58e42971f5597bc3'
+ 'acbccbc4dace958b4d7eeeb3879e6f80fe798ffb5e7be5375008970f6ee30c34')
+options=('!buildflags')
+
+prepare() {
+ export GOPATH="${srcdir}/gopath"
+ export PATH="${GOPATH}/bin:$PATH"
+ mkdir -p "${GOPATH}/src/github.com/${pkgname}-project"
+ mv "${srcdir}/${pkgname}-${pkgver}" "${GOPATH}/src/github.com/${pkgname}-project/${pkgname}"
+}
+
+build() {
+ cd "${GOPATH}/src/github.com/${pkgname}-project/${pkgname}"
+ make
+}
+
+package() {
+ export GOPATH="${srcdir}/gopath"
+ export PATH="${GOPATH}/bin:$PATH"
+ cd "${GOPATH}"
+ install -Dm0755 "bin/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ cd "${GOPATH}/src/github.com/${pkgname}-project/${pkgname}"
+ install -Dm0644 "contrib/systemd/${pkgname}-agent.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}-agent.service"
+ install -Dm0644 "contrib/systemd/${pkgname}-analyzer.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}-analyzer.service"
+ install -Dm0644 "etc/${pkgname}.yml.default" "${pkgdir}/etc/${pkgname}/${pkgname}.yml"
+ cd "${srcdir}"
+ install -Dm644 "${pkgname}.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
+ install -Dm644 "${pkgname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
+}
diff --git a/skydive.sysusers b/skydive.sysusers
new file mode 100644
index 000000000000..bb5339c76711
--- /dev/null
+++ b/skydive.sysusers
@@ -0,0 +1 @@
+u skydive - - /var/lib/skydive
diff --git a/skydive.tmpfiles b/skydive.tmpfiles
new file mode 100644
index 000000000000..6d5e855690dc
--- /dev/null
+++ b/skydive.tmpfiles
@@ -0,0 +1 @@
+d /var/lib/skydive 0750 skydive skydive