summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatheus2015-09-16 01:07:12 -0300
committerMatheus2015-09-16 01:07:12 -0300
commit8548563246e5491944109c588c617d926f3b5d80 (patch)
tree4539c614bd0ad5616c5997e667b8061f69593c34
downloadaur-8548563246e5491944109c588c617d926f3b5d80.tar.gz
initial submission
-rw-r--r--.SRCINFO14
-rwxr-xr-xPKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..877c1af6d201
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = skype-desktop-bin
+ pkgdesc = An unofficial client of Skype for Linux, running on top of Node Webkit.
+ pkgver = c153b15
+ pkgrel = 1
+ url = https://github.com/haskellcamargo/skype-unofficial-client
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = make
+ source = git+https://github.com/haskellcamargo/skype-unofficial-client.git
+ md5sums = SKIP
+
+pkgname = skype-desktop-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..a3990bb42f38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Trevor <assviolat0r at live dot com>
+pkgname=skype-desktop-bin
+pkgver=c153b15
+pkgrel=1
+pkgdesc="An unofficial client of Skype for Linux, running on top of Node Webkit."
+arch=('i686' 'x86_64')
+url="https://github.com/haskellcamargo/skype-unofficial-client"
+license=('MIT')
+depends=()
+makedepends=('make')
+#options=('!strip')
+#[ "$CARCH" = "i686" ] && _platform=linux_32
+#[ "$CARCH" = "x86_64" ] && _platform=linux_64
+source=(git+https://github.com/haskellcamargo/skype-unofficial-client.git)
+md5sums=('SKIP')
+_gitname=skype-unofficial-client
+
+pkgver () {
+ cd $_gitname
+ echo $(git describe --always | sed 's/-/./g')
+}
+
+package() {
+ cd $_gitname
+ sudo make
+}
+