summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Santini2015-09-25 09:32:37 +0200
committerGiovanni Santini2015-09-25 09:32:37 +0200
commitb0448439d8a6a42f4b3ec5fc0fc914ff28d0426c (patch)
tree9b6ed65ea432f10ae64ef432025a239594fb9cd8
parent14557fb26440a60946f55793c28ebee49562adac (diff)
downloadaur-b0448439d8a6a42f4b3ec5fc0fc914ff28d0426c.tar.gz
Fixing build and making it more general
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Adding-PREFIX-variable.patch57
-rwxr-xr-xPKGBUILD26
3 files changed, 79 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 173912ed8d0a..b04f850006ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = skype-desktop-bin
pkgdesc = An unofficial client of Skype for Linux, running on top of Node Webkit.
- pkgver = c153b15
+ pkgver = 8594308
pkgrel = 1
url = https://github.com/haskellcamargo/skype-unofficial-client
arch = i686
@@ -10,7 +10,9 @@ pkgbase = skype-desktop-bin
makedepends = git
depends = gconf
source = git+https://github.com/haskellcamargo/skype-unofficial-client.git
+ source = 0001-Adding-PREFIX-variable.patch
md5sums = SKIP
+ md5sums = c419c56f8551b794ce355b955ea63b96
pkgname = skype-desktop-bin
diff --git a/0001-Adding-PREFIX-variable.patch b/0001-Adding-PREFIX-variable.patch
new file mode 100644
index 000000000000..34a6dbbbe28a
--- /dev/null
+++ b/0001-Adding-PREFIX-variable.patch
@@ -0,0 +1,57 @@
+From 0e3a852047cbaa4cfc237ebfc993d84824f05db4 Mon Sep 17 00:00:00 2001
+From: Giovanni Santini <giovannisantini93@yahoo.it>
+Date: Fri, 25 Sep 2015 09:17:20 +0200
+Subject: [PATCH] Adding PREFIX variable
+Allows users to install in a different (root!) path, useful for packaging.
+
+---
+ Makefile | 30 +++++++++++++++---------------
+ 1 file changed, 15 insertions(+), 15 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index e8798d9..e1ed89d 100755
+--- a/Makefile
++++ b/Makefile
+@@ -4,24 +4,24 @@
+ RESOURCE = ./resource
+ BIN = ./bin
+ SRC = ./src
++PREFIX =
+
+ linux_x64:
+- cp $(RESOURCE)/skype.png /usr/share/icons/hicolor/512x512/apps/
++ cp $(RESOURCE)/skype.png $(PREFIX)/usr/share/icons/hicolor/512x512/apps/
+ cp $(SRC)/package.json $(BIN)/linux_x64
+- mkdir -p /opt/skype_unofficial_client
+- cp -R $(BIN)/linux_x64/* /opt/skype_unofficial_client
+- chmod +x -R /opt/skype_unofficial_client
+- cp $(SRC)/Skype.desktop /usr/share/applications
+- cp $(SRC)/skype-desktop /usr/bin
+- chmod +x $(SRC)/skype-desktop
++ mkdir -p $(PREFIX)/opt/skype_unofficial_client
++ cp -R $(BIN)/linux_x64/* $(PREFIX)/opt/skype_unofficial_client
++ chmod +x -R $(PREFIX)/opt/skype_unofficial_client
++ cp $(SRC)/Skype.desktop $(PREFIX)/usr/share/applications
++ chmod +x $(SRC)/skype-desktop
++ cp $(SRC)/skype-desktop $(PREFIX)/usr/bin
+
+ linux_x86:
+- cp $(RESOURCE)/skype.png /usr/share/icons/hicolor/512x512/apps/
++ cp $(RESOURCE)/skype.png $(PREFIX)/usr/share/icons/hicolor/512x512/apps/
+ cp $(SRC)/package.json $(BIN)/linux_x86
+- mkdir -p /opt/skype_unofficial_client
+- cp -R $(BIN)/linux_x86/* /opt/skype_unofficial_client
+- chmod +x -R /opt/skype_unofficial_client
+- cp $(SRC)/Skype.desktop /usr/share/applications
+- cp $(SRC)/skype-desktop /usr/bin
+- chmod +x $(SRC)/skype-desktop
+-
++ mkdir -p $(PREFIX)/opt/skype_unofficial_client
++ cp -R $(BIN)/linux_x86/* $(PREFIX)/opt/skype_unofficial_client
++ chmod +x -R $(PREFIX)/opt/skype_unofficial_client
++ cp $(SRC)/Skype.desktop $(PREFIX)/usr/share/applications
++ chmod +x $(SRC)/skype-desktop
++ cp $(SRC)/skype-desktop $(PREFIX)/usr/bin
+--
+2.5.3
+
diff --git a/PKGBUILD b/PKGBUILD
index c0f2ba40ab7b..6708c3628f70 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Trevor <assviolat0r at live dot com>
+# Co-maintainer: Giovanni 'ItachiSan' Santini <giovannisantini93@yahoo.it>
pkgname=skype-desktop-bin
-pkgver=c153b15
+pkgver=8594308
pkgrel=1
pkgdesc="An unofficial client of Skype for Linux, running on top of Node Webkit."
arch=('i686' 'x86_64')
@@ -9,10 +10,13 @@ license=('MIT')
depends=('gconf')
makedepends=('make' 'git')
#options=('!strip')
-#[ "$CARCH" = "i686" ] && _platform=linux_32
-#[ "$CARCH" = "x86_64" ] && _platform=linux_64
-source=(git+https://github.com/haskellcamargo/skype-unofficial-client.git)
-md5sums=('SKIP')
+# Actually check for the architecture (Trevor, is so much juice! :D)
+[ "$CARCH" = "i686" ] && _platform=linux_x86
+[ "$CARCH" = "x86_64" ] && _platform=linux_x64
+source=(git+https://github.com/haskellcamargo/skype-unofficial-client.git
+ 0001-Adding-PREFIX-variable.patch)
+md5sums=('SKIP'
+ 'c419c56f8551b794ce355b955ea63b96')
_gitname=skype-unofficial-client
pkgver () {
@@ -20,8 +24,16 @@ pkgver () {
echo $(git describe --always | sed 's/-/./g')
}
+prepare() {
+ cd "$srcdir/$_gitname"
+ patch -p1 -i ../0001-Adding-PREFIX-variable.patch
+}
+
package() {
- cd $_gitname
- sudo make
+ cd "$srcdir/$_gitname" # Git name and $pkgname differs
+ # Creating missing folders
+ mkdir -p "$pkgdir/usr/share/icons/hicolor/512x512/apps/"
+ # Do the actual installation
+ make PREFIX=$pkgdir $_platform
}