summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlois Nespor2016-03-02 14:53:45 +0100
committerAlois Nespor2016-03-02 14:53:45 +0100
commit4719c830c8209dfa8b24a6207cb29d0adcd11fee (patch)
tree68626fec86307bdaf3fa73ace78b0b248d32cfb2
downloadaur-4719c830c8209dfa8b24a6207cb29d0adcd11fee.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--05sskype1
-rw-r--r--PKGBUILD31
-rw-r--r--client.conf1
-rw-r--r--sskype4
-rw-r--r--sskype.desktop11
-rw-r--r--sskype.install16
7 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b15f4f4c0719
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Wed Mar 2 13:53:23 UTC 2016
+pkgbase = skype-secure
+ pkgdesc = works like skype-restricted, but wraps around already installed skype binary
+ pkgver = 2
+ pkgrel = 2
+ url = http://www.skype.com/
+ install = sskype.install
+ arch = any
+ license = custom
+ depends = skype
+ depends = xorg-xhost
+ depends = sudo
+ provides = sskype
+ conflicts = skype-restricted
+ source = sskype
+ source = 05sskype
+ source = client.conf
+ source = sskype.desktop
+ md5sums = bc1544ee88f58532df33465c8bb80050
+ md5sums = f94124126da310ba8e2a9aefb63dde90
+ md5sums = 46775f06fd9d6c4ad5ff3a221d4912ff
+ md5sums = 413a9872da5142a2bdb68b8330b512dc
+
+pkgname = skype-secure
+
diff --git a/05sskype b/05sskype
new file mode 100644
index 000000000000..43e8c25ea047
--- /dev/null
+++ b/05sskype
@@ -0,0 +1 @@
+ALL ALL=(_skype) NOPASSWD: /usr/bin/skype
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9724f2e1fd55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: koneu <koneu93 AT googlemail DOT com>
+
+pkgname=skype-secure
+pkgver=2
+pkgrel=2
+arch=(any)
+pkgdesc="works like skype-restricted, but wraps around already installed skype binary"
+url="http://www.skype.com/"
+license=('custom')
+install=sskype.install
+conflicts=('skype-restricted')
+
+depends=(skype xorg-xhost sudo)
+provides=('sskype')
+
+source=(sskype 05sskype client.conf sskype.desktop)
+md5sums=('bc1544ee88f58532df33465c8bb80050'
+ 'f94124126da310ba8e2a9aefb63dde90'
+ '46775f06fd9d6c4ad5ff3a221d4912ff'
+ '413a9872da5142a2bdb68b8330b512dc')
+
+package() {
+ install -D "$startdir/sskype" "$pkgdir/usr/bin/sskype"
+
+ install -dm 750 "$pkgdir/etc/sudoers.d"
+ install -m 440 "$startdir/05sskype" "$pkgdir/etc/sudoers.d/05sskype"
+
+ install -Dm 644 "$startdir/client.conf" "$pkgdir/etc/default/sskype/.pulse/client.conf"
+
+ install -Dm 644 "$startdir/sskype.desktop" "$pkgdir/usr/share/applications/sskype.desktop"
+}
diff --git a/client.conf b/client.conf
new file mode 100644
index 000000000000..a14b103865b9
--- /dev/null
+++ b/client.conf
@@ -0,0 +1 @@
+default-server = 127.0.0.1
diff --git a/sskype b/sskype
new file mode 100644
index 000000000000..9d1288bb8d0f
--- /dev/null
+++ b/sskype
@@ -0,0 +1,4 @@
+#!/bin/sh
+xhost +si:localuser:_skype &&
+exec sudo -u _skype /usr/bin/skype "$@"
+xhost -si:localuser:_skype
diff --git a/sskype.desktop b/sskype.desktop
new file mode 100644
index 000000000000..71709763b1bf
--- /dev/null
+++ b/sskype.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=SkypeSecure
+Comment=Skype Internet Telephony
+Exec=sskype %U
+Icon=skype.png
+Terminal=false
+Type=Application
+Encoding=UTF-8
+Categories=Network;Application;
+MimeType=x-scheme-handler/skype;
+X-KDE-Protocols=skype
diff --git a/sskype.install b/sskype.install
new file mode 100644
index 000000000000..7810229864ec
--- /dev/null
+++ b/sskype.install
@@ -0,0 +1,16 @@
+post_install() {
+ useradd -U -G audio,video -k /etc/default/sskype -m -s /sbin/nologin _skype
+ echo "Special setup required for Pulse Audio:"
+ echo "(many thanks to kurnevsky)"
+ echo "add 'load-module module-native-protocol-tcp auth-ip-acl=127.0.0.1'"
+ echo "to ~/.pulse/default.pa"
+ echo ""
+ echo "If you are upgrading from a version that worked without pulse,"
+ echo "completely uninstall skype-secure before installing it."
+}
+
+post_remove() {
+ killall -u _skype
+ sleep 3
+ userdel -r _skype
+}