summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2018-11-08 14:41:10 +1000
committerMark Blakeney2018-11-08 14:41:10 +1000
commit0dcfb6e9d5893c16055e557708088ae4067fc1cc (patch)
tree3e580cc67ce346f37fc13bfa719787c38ad35d70
parentdf1e0df6f76c33b6cead2adda1574e7de4e5d62a (diff)
downloadaur-0dcfb6e9d5893c16055e557708088ae4067fc1cc.tar.gz
Replace all 16px tray icons with 32px
Should fix corrupted tray icons. See https://answers.microsoft.com/en-us/skype/forum/skype_linux-skype_startms-skype_installms/system-tray-icon-in-xfce/d3f162bf-0bbf-481b-90a1-f43cae9a86cc?messageId=90d7e7da-7ef2-4922-af24-a7093f4a7712.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2c683b609ca..c2c35313749c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = skypeforlinux-preview-bin
pkgdesc = Skype for Linux - Preview/Insider Version
pkgver = 8.34.76.37
- pkgrel = 1
+ pkgrel = 2
url = http://www.skype.com
arch = x86_64
license = custom
+ makedepends = asar
depends = gtk3
depends = libxss
depends = gconf
diff --git a/PKGBUILD b/PKGBUILD
index 01c557208cd3..78315b75852e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,14 @@
_pkgname=skypeforlinux
pkgname=$_pkgname-preview-bin
pkgver=8.34.76.37
-pkgrel=1
+pkgrel=2
pkgdesc="Skype for Linux - Preview/Insider Version"
arch=("x86_64")
url="http://www.skype.com"
license=("custom")
depends=("gtk3" "libxss" "gconf" "alsa-lib" "libxtst" "libsecret" "nss" "glibc>=2.28-4")
optdepends=("gnome-keyring")
+makedepends=("asar")
conflicts=("$_pkgname" "$_pkgname-bin" "$_pkgname-stable-bin" "$_pkgname-beta-bin" "skype")
provides=("$_pkgname" "skype")
replaces=("$_pkgname-bin")
@@ -25,6 +26,18 @@ package() {
mv "$pkgdir/usr/share/$_pkgname/LICENSES.chromium.html" \
"$pkgdir/usr/share/licenses/$pkgname/"
rm -rf "$pkgdir/opt"
+
+ # Replace all 16px tray icons with 32px.
+ _p="/usr/share/skypeforlinux/resources"
+ cd "$pkgdir/$_p"
+ asar extract app.asar _tmp
+ cd _tmp/images/tray
+ find . -iname '*@2x.png' | while read f; do
+ mv $f ${f//@2x/}
+ done
+ cd "$pkgdir/$_p"
+ asar pack _tmp app.asar
+ rm -rf _tmp
}
# vim:set ts=2 sw=2 et: