summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2018-08-17 07:59:29 +1000
committerMark Blakeney2018-08-17 08:00:28 +1000
commitbeba0a400e256225272ceb15870386f104076d3d (patch)
tree5114ef14375ec8a0bb65f303866cc483ac049d64
parentefb03a335c4cea09381f6ae79717593d23e60630 (diff)
downloadaur-beba0a400e256225272ceb15870386f104076d3d.tar.gz
Revert glibc hack now glibc 2.28-4 includes fix
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 7 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb2776717660..b52451050bc8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = skypeforlinux-preview-bin
pkgdesc = Skype for Linux - Preview/Insider Version
pkgver = 8.29.76.16
- pkgrel = 1
+ pkgrel = 2
url = http://www.skype.com
arch = x86_64
license = custom
- makedepends = patchelf
depends = gtk3
depends = libxss
depends = gconf
@@ -13,6 +12,7 @@ pkgbase = skypeforlinux-preview-bin
depends = libxtst
depends = libsecret
depends = nss
+ depends = glibc>=2.28-4
optdepends = gnome-keyring
provides = skypeforlinux
provides = skype
@@ -22,13 +22,8 @@ pkgbase = skypeforlinux-preview-bin
conflicts = skypeforlinux-beta-bin
conflicts = skype
replaces = skypeforlinux-bin
- noextract = glibc-2.27-3-x86_64.pkg.tar.xz
- options = !strip
- options = staticlibs
source = https://repo.skype.com/deb/pool/main/s/skypeforlinux/skypeforlinux_8.29.76.16_amd64.deb
- source = https://archive.archlinux.org/packages/g/glibc/glibc-2.27-3-x86_64.pkg.tar.xz
sha256sums = 0323599694f293c7063b785ad533ac1cf8981bfd875cce896df956e63004c72f
- sha256sums = a9e1b18d7f613be660556dbd6883781e88a0f5113230147e230d3e2f268792dc
pkgname = skypeforlinux-preview-bin
diff --git a/PKGBUILD b/PKGBUILD
index 9e6ba3e5fdec..8bee2c22b15b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,39 +4,27 @@
_pkgname=skypeforlinux
pkgname=$_pkgname-preview-bin
pkgver=8.29.76.16
-pkgrel=1
+pkgrel=2
pkgdesc="Skype for Linux - Preview/Insider Version"
arch=("x86_64")
url="http://www.skype.com"
license=("custom")
-depends=("gtk3" "libxss" "gconf" "alsa-lib" "libxtst" "libsecret" "nss")
+depends=("gtk3" "libxss" "gconf" "alsa-lib" "libxtst" "libsecret" "nss" "glibc>=2.28-4")
optdepends=("gnome-keyring")
-makedepends=("patchelf")
-options=("!strip" "staticlibs")
conflicts=("$_pkgname" "$_pkgname-bin" "$_pkgname-stable-bin" "$_pkgname-beta-bin" "skype")
provides=("$_pkgname" "skype")
replaces=("$_pkgname-bin")
source=(
"https://repo.skype.com/deb/pool/main/s/$_pkgname/${_pkgname}_${pkgver}_amd64.deb"
-"https://archive.archlinux.org/packages/g/glibc/glibc-2.27-3-${CARCH}.pkg.tar.xz"
)
-noextract=("glibc-2.27-3-${CARCH}.pkg.tar.xz")
-sha256sums=('0323599694f293c7063b785ad533ac1cf8981bfd875cce896df956e63004c72f'
- 'a9e1b18d7f613be660556dbd6883781e88a0f5113230147e230d3e2f268792dc')
+sha256sums=('0323599694f293c7063b785ad533ac1cf8981bfd875cce896df956e63004c72f')
package() {
- _ldir="/usr/share/$_pkgname"
- _pdir="$pkgdir/$_ldir"
- _pexe="$_pdir/$_pkgname"
tar -xJC "$pkgdir" -f data.tar.xz
install -d "$pkgdir/usr/share/licenses/$pkgname"
- mv "$_pdir/LICENSES.chromium.html" "$pkgdir/usr/share/licenses/$pkgname/"
+ mv "$pkgdir/usr/share/$_pkgname/LICENSES.chromium.html" \
+ "$pkgdir/usr/share/licenses/$pkgname/"
rm -rf "$pkgdir/opt"
- mkdir -p "$_pdir/glibc"
- tar -xJC "$_pdir/glibc" -f "glibc-2.27-3-$CARCH.pkg.tar.xz"
- rm "$_pdir/glibc/"{.BUILDINFO,.INSTALL,.MTREE,.PKGINFO}
- patchelf --set-interpreter "$_ldir/glibc/usr/lib/ld-linux-x86-64.so.2" "$_pexe"
- patchelf --set-rpath "$_ldir:$_ldir/glibc/usr/lib" "$_pexe"
}
# vim:set ts=2 sw=2 et: