summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2018-01-11 13:55:43 +1000
committerMark Blakeney2018-01-11 13:55:43 +1000
commit2205204c96365bd1ac1b9e53588f076dd08e5b36 (patch)
tree6f1a007c3de242d2666029d01d6b1abd8ea4d809
downloadaur-2205204c96365bd1ac1b9e53588f076dd08e5b36.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore5
-rw-r--r--Makefile19
-rw-r--r--PKGBUILD27
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8612ff590cbf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = skypeforlinux-stable-bin
+ pkgdesc = Skype for Linux - Stable/Release Version
+ pkgver = 8.13.0.2
+ pkgrel = 1
+ url = http://www.skype.com
+ arch = x86_64
+ license = custom
+ depends = gtk2
+ depends = libxss
+ depends = gconf
+ depends = alsa-lib
+ depends = libxtst
+ depends = libsecret
+ depends = nss
+ optdepends = gnome-keyring
+ provides = skypeforlinux
+ conflicts = skypeforlinux
+ conflicts = skypeforlinux-bin
+ conflicts = skypeforlinux-stable-bin-preview-bin
+ conflicts = skypeforlinux-stable-bin-beta-bin
+ source = https://repo.skype.com/deb/pool/main/s/skypeforlinux/skypeforlinux_8.13.0.2_amd64.deb
+ sha256sums = c931f4a30e5bf34e74393e0eb38190811dcef25e8598a786c4a97387bcd9e196
+
+pkgname = skypeforlinux-stable-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0a6c7c718bce
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.tar
+*.deb
+*.[gx]z
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..539f0b4dfdc6
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,19 @@
+nam = $(shell sed -n 's/^_pkgname=//p' PKGBUILD)
+src = PKGBUILD
+inf = .SRCINFO
+
+all: sum $(inf) check
+
+$(inf): $(src)
+ makepkg --printsrcinfo >$@
+
+check: $(src)
+ namcap $^
+
+sum: $(src)
+ updpkgsums
+
+clean:
+ rm -rf $(inf) $(nam)-* *.tar.xz *.tar.gz pkg/ src/ *.part
+
+# vim: se ts=4:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88a0dc2ef46c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: mark.blakeney at bullet-systems dot net
+# Original Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+_pkgname=skypeforlinux
+pkgname=$_pkgname-stable-bin
+pkgver=8.13.0.2
+pkgrel=1
+pkgdesc="Skype for Linux - Stable/Release Version"
+arch=("x86_64")
+url="http://www.skype.com"
+license=("custom")
+depends=("gtk2" "libxss" "gconf" "alsa-lib" "libxtst" "libsecret" "nss")
+optdepends=("gnome-keyring")
+conflicts=("$_pkgname" "$_pkgname-bin" "$pkgname-preview-bin" "$pkgname-beta-bin")
+provides=("$_pkgname")
+source=("https://repo.skype.com/deb/pool/main/s/$_pkgname/${_pkgname}_${pkgver}_amd64.deb")
+sha256sums=('c931f4a30e5bf34e74393e0eb38190811dcef25e8598a786c4a97387bcd9e196')
+
+package() {
+ tar -xJC "$pkgdir" -f data.tar.xz
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ mv "$pkgdir/usr/share/$_pkgname/LICENSES.chromium.html" \
+ "${pkgdir}/usr/share/licenses/$pkgname/"
+ rm -rf "$pkgdir/opt"
+}
+
+# vim:set ts=2 sw=2 et: