summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMr.Smith19742023-08-02 10:37:32 +0300
committerMr.Smith19742023-08-02 10:37:32 +0300
commite03670a021d6bf73bff2d50fe89dc589afaa76e4 (patch)
tree7242d2a33f51f742a7208c828e43fbab543b92b7
downloadaur-e03670a021d6bf73bff2d50fe89dc589afaa76e4.tar.gz
Initial build
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..939dcf7d7683
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = skytechx-git
+ pkgdesc = SkytechX is free astronomical planetarium for rendering real objects (stars, planets, comets etc.) on the map
+ pkgver = r390.31d588a
+ pkgrel = 1
+ url = https://github.com/tstibor/skytechx
+ arch = x86_64
+ license = GPL
+ makedepends = qt5-multimedia
+ makedepends = qt5-script
+ makedepends = qt5-charts
+ source = git+https://github.com/tstibor/skytechx.git
+ sha256sums = SKIP
+
+pkgname = skytechx-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7db010ccf938
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+_pkgname=skytechx
+pkgname=skytechx-git
+pkgver=r390.31d588a
+pkgrel=1
+pkgdesc="SkytechX is free astronomical planetarium for rendering real objects (stars, planets, comets etc.) on the map"
+arch=(x86_64)
+url="https://github.com/tstibor/skytechx"
+license=(GPL)
+makedepends=('qt5-multimedia' 'qt5-script' 'qt5-charts')
+source=("git+https://github.com/tstibor/skytechx.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${srcdir}
+ [[ -d build ]] && rm -rf build
+
+ cmake \
+ -S "skytechx" \
+ -B build \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_STATIC=NO
+ cmake --build build
+}
+
+package() {
+ cd "${srcdir}/build"
+ DESTDIR="$pkgdir" cmake -P cmake_install.cmake
+}