summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSuperITMan2020-04-14 17:26:05 +0200
committerSuperITMan2020-04-15 17:33:26 +0200
commit7888fc6f1ed3603188931899c8944dba2665661a (patch)
tree901fa8d46ee27d2afb2d2a743ea376156396ac9b
parentebc2bf30aad2a952da73800815bf189618818356 (diff)
downloadaur-7888fc6f1ed3603188931899c8944dba2665661a.tar.gz
update to 4.3.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
-rw-r--r--darkify_slack.js12
-rw-r--r--slack-desktop-black-theme-night-mood.patch8
4 files changed, 33 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4d9aa7f0b17..669eb998fab1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = slack-desktop-black-theme-night-mood
pkgdesc = Slack Desktop (Beta) for Linux, with black theme night mood patch
- pkgver = 4.1.2
+ pkgver = 4.3.2
pkgrel = 1
url = https://slack.com/downloads
arch = x86_64
@@ -18,15 +18,15 @@ pkgbase = slack-desktop-black-theme-night-mood
optdepends = gnome-keyring
conflicts = slack-desktop
conflicts = slack-desktop-dark
- noextract = slack-desktop-4.1.2-amd64.deb
- source = https://downloads.slack-edge.com/linux_releases/slack-desktop-4.1.2-amd64.deb
- source = slack-4-4.1.2-1::https://raw.githubusercontent.com/caiceA/slack-raw/766623d/slack-4
+ noextract = slack-desktop-4.3.2-amd64.deb
+ source = https://downloads.slack-edge.com/linux_releases/slack-desktop-4.3.2-amd64.deb
+ source = slack-4-4.3.2-1-dark.css::https://raw.githubusercontent.com/caiceA/slack-black-theme/c09f3e0fe9c3f362f3c8c9e55554da076a04a354/slack-dark-mode.css
source = darkify_slack.js
source = slack-desktop-black-theme-night-mood.patch
- sha256sums = 70667911fff7f338d68137eaae93daf02c2c0f68f51db25a76345418d0142b28
- sha256sums = dfddb59821d99d40a2bb2795ac6109f33071d2e8ea89778cde20675a8df0ab8a
- sha256sums = 13fc4ea2c9bfd113e123a7f74375f17c17a7256d7481f9acacb466088b913418
- sha256sums = c952eb32dd59beff9fc5374853b04acde4a60ed8c39934fcd0b66829455d594d
+ sha256sums = 38ebbf79365226b83527cd754474ad680b0c83bd420d0fe1e5e4626889535908
+ sha256sums = 341056a19165860715c0ba12911c930d04214c51ee863bbd5cad4e2b2be78f68
+ sha256sums = b5c2d94ef8bac73c7a97bcde303505f20d6b8561dfd86ed2278b4109e0c5412c
+ sha256sums = d351d8ff3eee0006d1c66e3efec60a78ae8cc10fd8c3042e8d899125a1c4bf47
pkgname = slack-desktop-black-theme-night-mood
diff --git a/PKGBUILD b/PKGBUILD
index 0eb7534a7458..bb110fc5d5d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,10 @@
# Contributor: Kyle Manna <kyle(at)kylemanna(dot)com>
pkgname=slack-desktop-black-theme-night-mood
-pkgver=4.1.2
+pkgver=4.3.2
pkgrel=1
pkgdesc="Slack Desktop (Beta) for Linux, with black theme night mood patch"
-cssver=766623d
+cssver=c09f3e0fe9c3f362f3c8c9e55554da076a04a354
arch=('x86_64')
url="https://slack.com/downloads"
license=('custom')
@@ -18,14 +18,14 @@ makedepends=('asar')
optdepends=('gnome-keyring')
conflicts=('slack-desktop' 'slack-desktop-dark')
source=("https://downloads.slack-edge.com/linux_releases/${pkgname%-black-theme-night-mood}-${pkgver}-amd64.deb"
- "slack-4-${pkgver}-${pkgrel}::https://raw.githubusercontent.com/caiceA/slack-raw/${cssver}/slack-4"
+ "slack-4-${pkgver}-${pkgrel}-dark.css::https://raw.githubusercontent.com/caiceA/slack-black-theme/${cssver}/slack-dark-mode.css"
"darkify_slack.js"
"${pkgname}.patch")
noextract=("${pkgname%-black-theme-night-mood}-${pkgver}-amd64.deb")
-sha256sums=('70667911fff7f338d68137eaae93daf02c2c0f68f51db25a76345418d0142b28'
- 'dfddb59821d99d40a2bb2795ac6109f33071d2e8ea89778cde20675a8df0ab8a'
- '13fc4ea2c9bfd113e123a7f74375f17c17a7256d7481f9acacb466088b913418'
- 'c952eb32dd59beff9fc5374853b04acde4a60ed8c39934fcd0b66829455d594d')
+sha256sums=('38ebbf79365226b83527cd754474ad680b0c83bd420d0fe1e5e4626889535908'
+ '341056a19165860715c0ba12911c930d04214c51ee863bbd5cad4e2b2be78f68'
+ 'b5c2d94ef8bac73c7a97bcde303505f20d6b8561dfd86ed2278b4109e0c5412c'
+ 'd351d8ff3eee0006d1c66e3efec60a78ae8cc10fd8c3042e8d899125a1c4bf47')
package() {
bsdtar -O -xf "slack-desktop-${pkgver}"*.deb data.tar.xz | bsdtar -C "${pkgdir}" -xJf -
@@ -48,14 +48,14 @@ package() {
# Insert the black theme directly into ssb-interop
lineno=$(sed -n '/HERE/=' darkify_slack.js)
- file="${resources}/app.asar.unpacked/dist/ssb-interop.bundle.js"
+ file="${resources}/app.asar.unpacked/dist/main-preload-entry-point.bundle.js"
# The last line of ssb-interop is comment, so a newline prevents the first line
# of our function from being commented out
echo "" >> $file
head -n $((lineno - 1)) darkify_slack.js >> $file
- sed -i -e '/\\E/d' -e 's/939393/ffffff/' slack-4-${pkgver}-${pkgrel}
- cat slack-4-${pkgver}-${pkgrel} >> $file
+ # sed -i -e '/\\E/d' -e 's/939393/ffffff/' slack-4-${pkgver}-${pkgrel}-dark.css
+ cat slack-4-${pkgver}-${pkgrel}-dark.css >> $file
tail -n +$((lineno + 1)) darkify_slack.js >> $file
# Repack with the theme change
diff --git a/darkify_slack.js b/darkify_slack.js
index ea7a32e7ce6e..c8697c9a0462 100644
--- a/darkify_slack.js
+++ b/darkify_slack.js
@@ -1,8 +1,18 @@
document.addEventListener("DOMContentLoaded", function() {
+ let customCustomCSS = `
+ :root {
+ /* Modify these to change your theme colors: */
+ --primary: #61AFEF;
+ --text: #ABB2BF;
+ --background: #282C34;
+ --background-elevated: #3B4048;
+}
+`;
+
let s = document.createElement('style');
s.type = 'text/css';
s.innerHTML = `
HERE
-`;
+` + customCustomCSS;
document.head.appendChild(s);
});
diff --git a/slack-desktop-black-theme-night-mood.patch b/slack-desktop-black-theme-night-mood.patch
index 4fd6ca921515..3b18fad30941 100644
--- a/slack-desktop-black-theme-night-mood.patch
+++ b/slack-desktop-black-theme-night-mood.patch
@@ -1,10 +1,10 @@
---- a/usr/share/applications/slack.desktop 2016-12-10 11:42:15.377200285 +0100
-+++ b/usr/share/applications/slack.desktop 2016-12-10 11:42:59.740826015 +0100
-@@ -3,7 +3,7 @@
+--- a/usr/share/applications/slack.desktop 2019-07-18 08:39:46.981221305 +0200
++++ b/usr/share/applications/slack.desktop 2019-07-18 08:40:45.194552861 +0200
+@@ -4,7 +4,7 @@
Comment=Slack Desktop
GenericName=Slack Client for Linux
-Exec=/usr/bin/slack %U
-+Exec=env LD_PRELOAD=/usr/lib/libcurl.so.3 /usr/bin/slack %U
++Exec=/usr/bin/slack -s %U
-Icon=/usr/share/pixmaps/slack.png
+Icon=slack
Type=Application