summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-07-06 14:35:43 -0500
committerLuis Martinez2021-07-06 14:35:43 -0500
commit258cc23909e3dad2a16cb24a4bd0af36278e1eee (patch)
treec72641943786972e56fb3c5177e236c1ba687969
parent30bc6ad8d49d7ff55533db3cb572f406d0813abf (diff)
downloadaur-258cc23909e3dad2a16cb24a4bd0af36278e1eee.tar.gz
update to 4.17.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD28
2 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9a952fe6fc7..4add0ff5d643 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = slack-electron
- pkgdesc = Slack Desktop (Beta) for Linux, modified to use the system 'electron' package instead of its own
- pkgver = 4.14.0
+ pkgdesc = Slack Desktop (Beta) for Linux, using the system Electron package
+ pkgver = 4.17.0
pkgrel = 1
url = https://slack.com/downloads
arch = x86_64
- license = custom: Slack
+ license = custom:proprietary
depends = electron
optdepends = libappindicator-gtk3: for notification indicator in the status bar on GNOME
provides = slack
provides = slack-desktop
conflicts = slack-desktop
- source = https://downloads.slack-edge.com/linux_releases/slack-desktop-4.14.0-amd64.deb
+ source = https://downloads.slack-edge.com/linux_releases/slack-desktop-4.17.0-amd64.deb
source = slack.sh
- sha256sums = cfa500b6c5109724d5fc123477d5e4c9740e332a56397a1413462da9358ac977
+ sha256sums = b1e7123f9e51d292b647fecd42236f2de3b3f863c631e8278d47e08b8aae8c1d
sha256sums = 4db11d083626a561129ca40e9cce7cc613c42223f138bb0136c62064c57471fd
pkgname = slack-electron
-
diff --git a/PKGBUILD b/PKGBUILD
index d8c06d0e6b33..b5975cac7491 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Yurii Kolesnykov <root@yurikoles.com>
pkgname=slack-electron
-_product="${pkgname%-electron}"
-pkgver=4.14.0
+_name="${pkgname%-electron}"
+pkgver=4.17.0
pkgrel=1
-pkgdesc="Slack Desktop (Beta) for Linux, modified to use the system 'electron' package instead of its own"
+pkgdesc="Slack Desktop (Beta) for Linux, using the system Electron package"
arch=('x86_64')
url="https://slack.com/downloads"
-license=('custom: Slack')
+license=('custom:proprietary')
depends=('electron')
optdepends=('libappindicator-gtk3: for notification indicator in the status bar on GNOME')
-provides=("${_product}" "${_product}-desktop")
-conflicts=("${_product}-desktop")
+provides=("${_name}" "${_name}-desktop")
+conflicts=("${_name}-desktop")
source=("https://downloads.slack-edge.com/linux_releases/slack-desktop-$pkgver-amd64.deb"
'slack.sh')
-sha256sums=('cfa500b6c5109724d5fc123477d5e4c9740e332a56397a1413462da9358ac977'
+sha256sums=('b1e7123f9e51d292b647fecd42236f2de3b3f863c631e8278d47e08b8aae8c1d'
'4db11d083626a561129ca40e9cce7cc613c42223f138bb0136c62064c57471fd')
prepare() {
@@ -24,16 +24,16 @@ prepare() {
sed -ri \
-e 's|^(Exec=.+/slack)(.+)|\1 -s\2|' \
-e 's/^Icon=.+slack\.png/Icon=slack/' \
- "usr/share/applications/${_product}.desktop"
+ "usr/share/applications/${_name}.desktop"
}
package() {
- install -Dm755 "${_product}.sh" "$pkgdir/usr/bin/${_product}"
+ install -Dm755 "${_name}.sh" "$pkgdir/usr/bin/${_name}"
- install -dm755 "$pkgdir/usr/lib/${_product}/"
- cp -dr --no-preserve=ownership usr/lib/${_product}/resources/* "$pkgdir/usr/lib/${_product}/"
+ install -dm755 "$pkgdir/usr/lib/${_name}/"
+ cp -dr --no-preserve=ownership usr/lib/${_name}/resources/* "$pkgdir/usr/lib/${_name}/"
- install -Dm644 "usr/share/applications/${_product}.desktop" -t "$pkgdir/usr/share/applications"
- install -Dm644 "usr/share/pixmaps/${_product}.png" -t "$pkgdir/usr/share/pixmaps"
- install -Dm644 "usr/lib/${_product}/LICENSE" "$pkgdir/usr/share/licenses/${_product}/LICENSE"
+ install -Dm644 "usr/share/applications/${_name}.desktop" -t "$pkgdir/usr/share/applications"
+ install -Dm644 "usr/share/pixmaps/${_name}.png" -t "$pkgdir/usr/share/pixmaps"
+ install -Dm644 "usr/lib/${_name}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}