summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2023-09-06 14:07:11 +0200
committerCarl Smedstad2023-09-29 09:08:28 +0200
commit9de6fc0eb975bd5bded03c8e6a3e638ec06fc980 (patch)
treee6fcde1480c0621cf309aa83bc1994d9eef79d5f
parent3df3d9388c44de2e6ce2dd701b593ad3ed530f00 (diff)
downloadaur-9de6fc0eb975bd5bded03c8e6a3e638ec06fc980.tar.gz
Publish version 4.34.120-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
-rw-r--r--slack.sh2
3 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49f5b3f4aecd..2075c5e6445b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = slack-electron
pkgdesc = Slack Desktop (Beta) for Linux, using the system Electron package
- pkgver = 4.33.90
+ pkgver = 4.34.120
pkgrel = 1
url = https://slack.com/downloads/linux
arch = x86_64
license = custom:proprietary
- depends = electron24
+ depends = electron
depends = gcc-libs
depends = glibc
+ depends = libx11
depends = libxkbfile
optdepends = libappindicator-gtk3: for notification indicator in the status bar on GNOME
provides = slack-desktop
conflicts = slack-desktop
- source = slack-electron-4.33.90.deb::https://downloads.slack-edge.com/releases/linux/4.33.90/prod/x64/slack-desktop-4.33.90-amd64.deb
+ source = slack-electron-4.34.120.deb::https://downloads.slack-edge.com/releases/linux/4.34.120/prod/x64/slack-desktop-4.34.120-amd64.deb
source = slack.sh
- sha256sums = 54a73d1f85d65c900b2973e7d737a00149d3dad37d9960f9dadff097a2e854dc
- sha256sums = 8b16b282a7304a86072ee84e95e0f685c7cc7f1689282de2b9c9475cb7be0a5a
+ sha256sums = fe2c78539f31cf8e58ae2250af428d00637f0d59af987113f31d7f0f8db48d72
+ sha256sums = 4db11d083626a561129ca40e9cce7cc613c42223f138bb0136c62064c57471fd
pkgname = slack-electron
diff --git a/PKGBUILD b/PKGBUILD
index d6a8adf3a7cd..6999e3d5a968 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,17 @@
# Contributor: Yurii Kolesnykov <root@yurikoles.com>
pkgname=slack-electron
-pkgver=4.33.90
+pkgver=4.34.120
pkgrel=1
pkgdesc="Slack Desktop (Beta) for Linux, using the system Electron package"
arch=(x86_64)
url="https://slack.com/downloads/linux"
license=(custom:proprietary)
depends=(
- electron24
+ electron
gcc-libs
glibc
+ libx11
libxkbfile
)
optdepends=('libappindicator-gtk3: for notification indicator in the status bar on GNOME')
@@ -25,8 +26,8 @@ source=(
'slack.sh'
)
sha256sums=(
- '54a73d1f85d65c900b2973e7d737a00149d3dad37d9960f9dadff097a2e854dc'
- '8b16b282a7304a86072ee84e95e0f685c7cc7f1689282de2b9c9475cb7be0a5a'
+ 'fe2c78539f31cf8e58ae2250af428d00637f0d59af987113f31d7f0f8db48d72'
+ '4db11d083626a561129ca40e9cce7cc613c42223f138bb0136c62064c57471fd'
)
prepare() {
@@ -34,9 +35,9 @@ prepare() {
# Enable slack silent mode and fix icon
sed -ri \
- -e 's|^(Exec=.+/slack)(.+)|\1 -s\2|' \
- -e 's/^Icon=.+slack\.png/Icon=slack/' \
- "usr/share/applications/slack.desktop"
+ -e 's|^(Exec=.+/slack)(.+)|\1 -s\2|' \
+ -e 's/^Icon=.+slack\.png/Icon=slack/' \
+ "usr/share/applications/slack.desktop"
}
package() {
diff --git a/slack.sh b/slack.sh
index 99f372142c07..083824f48b25 100644
--- a/slack.sh
+++ b/slack.sh
@@ -1,3 +1,3 @@
#!/bin/sh
-exec electron24 /usr/lib/slack/app.asar "$@"
+exec electron /usr/lib/slack/app.asar "$@"