summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-04-06 11:00:08 -0500
committerLuis Martinez2022-04-06 11:00:08 -0500
commitf9566bc1dc8bfaaed586e0f72a4bad0be49211d4 (patch)
treeab73b1dfe2517d00e43fd10b33e045448a6cf6a3
parentdd737e8c6eda8a2daffea9a211f55757cabcd483 (diff)
downloadaur-f9566bc1dc8bfaaed586e0f72a4bad0be49211d4.tar.gz
update to 4.25.1
* Pin `electron` package to a specific version (`electron18`). This package can break if the `electron` package pushes a major update. For now we will pin the `electron` dep to the `electron18` provides, but ultimately we're tracking against `electron`. Once we confirm that the package works against the newest `electron`, we'll bump the version.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--slack.sh2
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13f0ca8eccb6..f45e55bea723 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = slack-electron
pkgdesc = Slack Desktop (Beta) for Linux, using the system Electron package
- pkgver = 4.24.1
- pkgrel = 2
+ pkgver = 4.25.1
+ pkgrel = 1
url = https://slack.com/downloads
arch = x86_64
license = custom:proprietary
- depends = electron17
+ depends = electron18
optdepends = libappindicator-gtk3: for notification indicator in the status bar on GNOME
provides = slack-desktop
conflicts = slack-desktop
- source = slack-electron-4.24.1.deb::https://downloads.slack-edge.com/releases/linux/4.24.1/prod/x64/slack-desktop-4.24.1-amd64.deb
+ source = slack-electron-4.25.1.deb::https://downloads.slack-edge.com/releases/linux/4.25.1/prod/x64/slack-desktop-4.25.1-amd64.deb
source = slack.sh
- sha256sums = 2645bd4a319c7f7039efb6301ff9f7c790d28ca45a86f9e432ec8ba2580009d5
- sha256sums = eddf0c5c6d50c01023a5095b591d4bfd99dc37d610bf494ed004b9212326a09d
+ sha256sums = 9dd0d58a981c2c42d1676b22200bababbba62fadbe837c912f4537d750c2f089
+ sha256sums = 54f9b8ba18ea099d1bab7c3e3d5d7f31fd830dcbc8608a22c238de884d889b63
pkgname = slack-electron
diff --git a/PKGBUILD b/PKGBUILD
index 25d1d3cbd274..18eb4644f401 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,20 @@
# Contributor: Yurii Kolesnykov <root@yurikoles.com>
pkgname=slack-electron
-pkgver=4.24.1
-pkgrel=2
+pkgver=4.25.1
+pkgrel=1
pkgdesc="Slack Desktop (Beta) for Linux, using the system Electron package"
arch=('x86_64')
url="https://slack.com/downloads"
license=('custom:proprietary')
-depends=('electron17')
+depends=('electron18')
optdepends=('libappindicator-gtk3: for notification indicator in the status bar on GNOME')
provides=("slack-desktop")
conflicts=("slack-desktop")
source=("$pkgname-$pkgver.deb::https://downloads.slack-edge.com/releases/linux/$pkgver/prod/x64/slack-desktop-$pkgver-amd64.deb"
'slack.sh')
-sha256sums=('2645bd4a319c7f7039efb6301ff9f7c790d28ca45a86f9e432ec8ba2580009d5'
- 'eddf0c5c6d50c01023a5095b591d4bfd99dc37d610bf494ed004b9212326a09d')
+sha256sums=('9dd0d58a981c2c42d1676b22200bababbba62fadbe837c912f4537d750c2f089'
+ '54f9b8ba18ea099d1bab7c3e3d5d7f31fd830dcbc8608a22c238de884d889b63')
prepare() {
bsdtar -xf data.tar.xz
diff --git a/slack.sh b/slack.sh
index 78ca42a2d94f..dea639c2117a 100644
--- a/slack.sh
+++ b/slack.sh
@@ -1,3 +1,3 @@
#!/bin/sh
-exec electron17 /usr/lib/slack/app.asar "$@"
+exec electron18 /usr/lib/slack/app.asar "$@"