summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2022-05-29 09:16:37 +0200
committerJan Cholasta2022-05-29 09:16:37 +0200
commit0db8d2d9fd6bd244b3824e32aa917e97fed4ad5e (patch)
tree1696364c3237e5744cf6dbb253498ab501c670e3
parent81cc24ca6e7d0a70af4bf51b4c17deac0cfbf171 (diff)
parentd8e58c16de92d78a4dbf5e84d6a604d802608e2c (diff)
downloadaur-0db8d2d9fd6bd244b3824e32aa917e97fed4ad5e.tar.gz
slade-3.2.1-1
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Keep-up-wx3.0-compatibility.patch66
-rw-r--r--PKGBUILD16
3 files changed, 8 insertions, 84 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4241030b71ac..dfb52f80d886 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = slade
pkgdesc = SLADE3 Doom editor
- pkgver = 3.2.0
- pkgrel = 2
+ pkgver = 3.2.1
+ pkgrel = 1
url = http://slade.mancubus.net/
arch = i686
arch = x86_64
@@ -21,10 +21,8 @@ pkgbase = slade
depends = webkit2gtk
depends = wxgtk3>=3.0
depends = zlib
- source = https://github.com/sirjuddington/SLADE/archive/3.2.0.tar.gz
- source = 0001-Keep-up-wx3.0-compatibility.patch
- sha256sums = e23cb1238d184a13912231c22e96208d6dff4eb55f38181ae92d2b67f205dfa5
- sha256sums = 8f89b81ec2ef11581ddac8592ab45a3a90ea02711b07a732ee931359883350dc
+ source = https://github.com/sirjuddington/SLADE/archive/3.2.1.tar.gz
+ sha256sums = c327fa62ba491ac481d769700261d810128910007297fd9d9dbe26ac0e78bb2c
pkgname = slade
diff --git a/0001-Keep-up-wx3.0-compatibility.patch b/0001-Keep-up-wx3.0-compatibility.patch
deleted file mode 100644
index 5805d2f3377f..000000000000
--- a/0001-Keep-up-wx3.0-compatibility.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-From c25a58ec813d0f125dfee3a894969c5e604b1ab7 Mon Sep 17 00:00:00 2001
-From: Simon Judd <sirjuddington@gmail.com>
-Date: Thu, 14 Apr 2022 21:52:16 -0700
-Subject: [PATCH] Keep up wx3.0 compatibility
-
-I'd like to drop it ideally, but for now it'll stay
-
-Fix #1336
----
- src/Graphics/Icons.cpp | 15 +++++++++++++++
- src/UI/SAuiTabArt.cpp | 5 ++++-
- 2 files changed, 19 insertions(+), 1 deletion(-)
-
-diff --git a/src/Graphics/Icons.cpp b/src/Graphics/Icons.cpp
-index 61d5475c..67147f7e 100644
---- a/src/Graphics/Icons.cpp
-+++ b/src/Graphics/Icons.cpp
-@@ -373,7 +373,22 @@ wxBitmap loadPNGIcon(const IconDef& icon, int size, Point2i padding)
- bool icons::loadIcons()
- {
- // Check for dark mode
-+#if wxMAJOR_VERSION >= 3 && wxMINOR_VERSION >= 1
- ui_icons_dark = wxSystemSettings::GetAppearance().IsDark();
-+#else
-+ auto fg = wxSystemSettings::GetColour(wxSYS_COLOUR_WINDOWTEXT);
-+ auto fg_r = fg.Red();
-+ auto fg_g = fg.Green();
-+ auto fg_b = fg.Blue();
-+ auto bg = wxSystemSettings::GetColour(wxSYS_COLOUR_WINDOW);
-+ auto bg_r = bg.Red();
-+ auto bg_g = bg.Green();
-+ auto bg_b = bg.Blue();
-+ wxColour::MakeGrey(&fg_r, &fg_g, &fg_b);
-+ wxColour::MakeGrey(&bg_r, &bg_g, &bg_b);
-+ log::info("DARK MODE CHECK: FG {} BG {}", fg_r, bg_r);
-+ ui_icons_dark = fg_r > bg_r;
-+#endif
-
- // Get slade.pk3
- auto* res_archive = app::archiveManager().programResourceArchive();
-diff --git a/src/UI/SAuiTabArt.cpp b/src/UI/SAuiTabArt.cpp
-index 15aad09e..240de8b9 100644
---- a/src/UI/SAuiTabArt.cpp
-+++ b/src/UI/SAuiTabArt.cpp
-@@ -542,6 +542,7 @@ void SAuiDockArt::DrawCaption(wxDC& dc, wxWindow* window, const wxString& text,
- int caption_offset = 0;
- if (pane.icon.IsOk())
- {
-+#if wxMAJOR_VERSION >= 3 && wxMINOR_VERSION >= 1
- // Ensure the icon fits into the title bar.
- wxSize iconSize = pane.icon.GetSize();
- if (iconSize.y > rect.height)
-@@ -554,7 +555,9 @@ void SAuiDockArt::DrawCaption(wxDC& dc, wxWindow* window, const wxString& text,
- dc.DrawBitmap(pane.icon,
- rect.x+xOffset, rect.y+(rect.height-pane.icon.GetHeight())/2,
- true);
--
-+#else
-+ DrawIcon(dc, rect, pane);
-+#endif
- caption_offset += pane.icon.GetWidth() + px3;
- }
-
---
-2.36.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 7e10268ffcc3..57159203b8ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
pkgname=slade
-pkgver=3.2.0
-pkgrel=2
+pkgver=3.2.1
+pkgrel=1
pkgdesc='SLADE3 Doom editor'
arch=('i686' 'x86_64')
url='http://slade.mancubus.net/'
@@ -22,16 +22,8 @@ depends=('bzip2'
'zlib')
makedepends=('cmake'
'p7zip')
-source=("https://github.com/sirjuddington/SLADE/archive/${pkgver}.tar.gz"
- '0001-Keep-up-wx3.0-compatibility.patch')
-sha256sums=('e23cb1238d184a13912231c22e96208d6dff4eb55f38181ae92d2b67f205dfa5'
- '8f89b81ec2ef11581ddac8592ab45a3a90ea02711b07a732ee931359883350dc')
-
-prepare() {
- cd SLADE-${pkgver}
-
- patch -i "$srcdir"/0001-Keep-up-wx3.0-compatibility.patch -p 1
-}
+source=("https://github.com/sirjuddington/SLADE/archive/${pkgver}.tar.gz")
+sha256sums=('c327fa62ba491ac481d769700261d810128910007297fd9d9dbe26ac0e78bb2c')
build() {
cd SLADE-${pkgver}