summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2017-07-04 06:37:25 +0200
committerJan Cholasta2017-07-04 07:30:25 +0200
commitd216eb8d977c7c9bf21d7e90deba6489bfd9b18b (patch)
treed2b1b94a9c5dbf8fa239056980edaf907613208a
parent08b0389e01c6c84a497f9b3e0a8bbb73c2cc3e4e (diff)
downloadaur-d216eb8d977c7c9bf21d7e90deba6489bfd9b18b.tar.gz
slade-3.1.2_b2-3
* disable webview, as it was removed from wxgtk2
-rw-r--r--.SRCINFO5
-rw-r--r--0001-NO_WEBVIEW-fix-742.patch47
-rw-r--r--PKGBUILD16
3 files changed, 62 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6fee2da7d10..7df11d56baa0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = slade
pkgdesc = SLADE3 Doom editor
pkgver = 3.1.2_b2
- pkgrel = 2
+ pkgrel = 3
url = http://slade.mancubus.net/
arch = i686
arch = x86_64
@@ -21,13 +21,14 @@ pkgbase = slade
depends = libgl
depends = sfml>=2.4
depends = sfml<2.5
- depends = webkitgtk2
depends = wxgtk2>=3.0
depends = zlib
source = https://github.com/sirjuddington/SLADE/archive/3.1.2_b2.tar.gz
source = slade.desktop
+ source = 0001-NO_WEBVIEW-fix-742.patch
sha256sums = 7b473853acbddfc03b1821ebec13e61f0caf26a6718f88bc4136989df15f853c
sha256sums = e69d6e0da523c5d649bd51316fa827175b5858cb91b4ad311b2f0d0dedd8b9bb
+ sha256sums = 8df409857161d3b72097326f574daa778efde945edc2373d435537e05be5dc8e
pkgname = slade
diff --git a/0001-NO_WEBVIEW-fix-742.patch b/0001-NO_WEBVIEW-fix-742.patch
new file mode 100644
index 000000000000..1b56af54e80e
--- /dev/null
+++ b/0001-NO_WEBVIEW-fix-742.patch
@@ -0,0 +1,47 @@
+From 097d5be38f27e8d829fcb394877c1db623f066f6 Mon Sep 17 00:00:00 2001
+From: Jacendi <jacendi@protonmail.com>
+Date: Fri, 23 Jun 2017 03:06:19 +0400
+Subject: [PATCH] NO_WEBVIEW fix (#742)
+
+* Update MainEditor.cpp
+
+* Update MainWindow.cpp
+
+* Update MainEditor.cpp
+---
+ src/MainEditor/MainEditor.cpp | 3 ++-
+ src/MainEditor/UI/MainWindow.cpp | 3 ++-
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/src/MainEditor/MainEditor.cpp b/src/MainEditor/MainEditor.cpp
+index 0c024de2..cb219265 100644
+--- a/src/MainEditor/MainEditor.cpp
++++ b/src/MainEditor/MainEditor.cpp
+@@ -94,8 +94,9 @@ EntryPanel* MainEditor::currentEntryPanel()
+ {
+ return main_window->getArchiveManagerPanel()->currentArea();
+ }
+-
++#ifdef USE_WEBVIEW_STARTPAGE
+ void MainEditor::openDocs(string page_name)
+ {
+ main_window->openDocs(page_name);
+ }
++#endif
+diff --git a/src/MainEditor/UI/MainWindow.cpp b/src/MainEditor/UI/MainWindow.cpp
+index ecb0f875..92e183bd 100644
+--- a/src/MainEditor/UI/MainWindow.cpp
++++ b/src/MainEditor/UI/MainWindow.cpp
+@@ -921,7 +921,8 @@ void MainWindow::onHTMLLinkClicked(wxEvent& e)
+ string rs = href.Mid(9);
+ unsigned long index = 0;
+ rs.ToULong(&index);
+- SActionHandler::doAction("aman_recent", index);
++ SActionHandler::setWxIdOffset(index);
++ SActionHandler::doAction("aman_recent");
+ createStartPage();
+ }
+ else if (href.StartsWith("action://"))
+--
+2.13.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 93f73b3ec73e..fcfb3266c911 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_name=slade
pkgname=${_name}
pkgver=3.1.2_b2
-pkgrel=2
+pkgrel=3
pkgdesc='SLADE3 Doom editor'
arch=('i686' 'x86_64')
url='http://slade.mancubus.net/'
@@ -20,22 +20,30 @@ depends=('bzip2'
'libgl'
'sfml>=2.4'
'sfml<2.5'
- 'webkitgtk2'
'wxgtk2>=3.0'
'zlib')
makedepends=('cmake'
'imagemagick'
'p7zip')
source=("https://github.com/sirjuddington/SLADE/archive/${pkgver}.tar.gz"
- "${_name}.desktop")
+ "${_name}.desktop"
+ '0001-NO_WEBVIEW-fix-742.patch')
sha256sums=('7b473853acbddfc03b1821ebec13e61f0caf26a6718f88bc4136989df15f853c'
- 'e69d6e0da523c5d649bd51316fa827175b5858cb91b4ad311b2f0d0dedd8b9bb')
+ 'e69d6e0da523c5d649bd51316fa827175b5858cb91b4ad311b2f0d0dedd8b9bb'
+ '8df409857161d3b72097326f574daa778efde945edc2373d435537e05be5dc8e')
+
+prepare() {
+ cd SLADE-${pkgver}
+
+ patch -p1 -i"$srcdir"/0001-NO_WEBVIEW-fix-742.patch
+}
build() {
cd SLADE-${pkgver}
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DNO_WEBVIEW=ON \
.
make