summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2018-11-27 23:23:09 +0100
committerJan Cholasta2018-11-27 23:30:45 +0100
commit5c0a109a55c1bdc4eb7e5391b593a413998587cc (patch)
tree028ae8fa7b899d39b15bf692618bcdc2691e032c
parent8c6c3f2445047402caec80aa4ef2f48bfb8ea695 (diff)
downloadaur-5c0a109a55c1bdc4eb7e5391b593a413998587cc.tar.gz
slade-git-3.1.2+25+g26eb6709-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
-rw-r--r--slade.desktop10
3 files changed, 15 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9182211820c3..a217729e1fbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = slade-git
pkgdesc = SLADE3 Doom editor (git version)
- pkgver = 3.1.2_b5+47+g94dd36e7
+ pkgver = 3.1.2+25+g26eb6709
pkgrel = 1
url = http://slade.mancubus.net/
arch = i686
@@ -8,28 +8,25 @@ pkgbase = slade-git
license = GPL
makedepends = cmake
makedepends = git
- makedepends = imagemagick
makedepends = p7zip
depends = bzip2
depends = curl
- depends = desktop-file-utils
depends = fluidsynth
depends = freeimage
- depends = freetype2
depends = ftgl
depends = glew
- depends = gtk2
+ depends = glu
+ depends = gtk3
depends = libgl
depends = sfml>=2.5
depends = sfml<2.6
- depends = wxgtk2>=3.0
+ depends = webkit2gtk
+ depends = wxgtk3>=3.0
depends = zlib
provides = slade
conflicts = slade
source = slade::git://github.com/sirjuddington/SLADE.git
- source = slade.desktop
sha256sums = SKIP
- sha256sums = e69d6e0da523c5d649bd51316fa827175b5858cb91b4ad311b2f0d0dedd8b9bb
pkgname = slade-git
diff --git a/PKGBUILD b/PKGBUILD
index 4e0913b26bb2..fa0073de6a79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=slade
pkgname=${_name}-git
-pkgver=3.1.2_b5+47+g94dd36e7
+pkgver=3.1.2+25+g26eb6709
pkgrel=1
pkgdesc='SLADE3 Doom editor (git version)'
arch=('i686' 'x86_64')
@@ -10,27 +10,25 @@ url='http://slade.mancubus.net/'
license=('GPL')
depends=('bzip2'
'curl'
- 'desktop-file-utils'
'fluidsynth'
'freeimage'
- 'freetype2'
'ftgl'
'glew'
- 'gtk2'
+ 'glu'
+ 'gtk3'
'libgl'
'sfml>=2.5'
'sfml<2.6'
- 'wxgtk2>=3.0'
+ 'webkit2gtk'
+ 'wxgtk3>=3.0'
'zlib')
makedepends=('cmake'
'git'
'p7zip')
provides=("${_name}")
conflicts=("${_name}")
-source=("${_name}::git://github.com/sirjuddington/SLADE.git"
- "${_name}.desktop")
-sha256sums=('SKIP'
- 'e69d6e0da523c5d649bd51316fa827175b5858cb91b4ad311b2f0d0dedd8b9bb')
+source=("${_name}::git://github.com/sirjuddington/SLADE.git")
+sha256sums=('SKIP')
pkgver() {
cd slade
@@ -41,9 +39,11 @@ pkgver() {
build() {
cd slade
+ ln -sf /usr/bin/wx-config-gtk3 wx-config
+
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DNO_WEBVIEW=ON \
+ -DWITH_WXPATH=. \
.
make
}
diff --git a/slade.desktop b/slade.desktop
deleted file mode 100644
index c6796e083d73..000000000000
--- a/slade.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Type=Application
-Version=1.0
-Name=SLADE
-GenericName=Doom editor
-Icon=slade
-Exec=slade %F
-Terminal=false
-MimeType=application/x-doom-wad;application/x-pak;application/zip;inode/directory;
-Categories=GTK;Utility;Archiving;