summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2024-02-02 17:00:19 +0100
committerKlaus Alexander Seistrup2024-02-02 17:00:19 +0100
commitd54828268c04c6b076252a3f7055f0f97ca97038 (patch)
tree88a9d22c0516ae2c0ea42dbd21dd8f8760588b58
parentb73578a5b885d8019eacc850c81e1d25b6c8e28d (diff)
downloadaur-d54828268c04c6b076252a3f7055f0f97ca97038.tar.gz
New upstream release: pre2.3.4-9
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
-rw-r--r--slang-snapshot.changelog23
3 files changed, 38 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9c686a791e0..c5c920733f26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = slang-snapshot
pkgdesc = S-Lang is a powerful interpreted language (development snapshot)
- pkgver = 2.3.4.8
- pkgrel = 7
+ pkgver = 2.3.4.9
+ pkgrel = 1
url = https://jedsoft.org/snapshots/
+ changelog = slang-snapshot.changelog
arch = aarch64
arch = armv7h
arch = i686
@@ -22,10 +23,10 @@ pkgbase = slang-snapshot
options = lto
options = !makeflags
backup = etc/slsh.rc
- source = https://jedsoft.org/snapshots/slang-pre2.3.4-8.tar.gz
+ source = https://jedsoft.org/snapshots/slang-pre2.3.4-9.tar.gz
validpgpkeys = AE962A02D29BFE4A4BB2805FDE401E0D5873000A
- md5sums = c740ca7ded82fa29849046ca33c572b1
- sha256sums = bd2de566dba919a0cc230b970236c89b095d693cc15344e28f7f9d4e646b9a6b
- sha512sums = bca104861f947b8a7a318c0cf4128be236eea603f0ca73125d7609d6ff4a7a425d99388e6df64f2d5b1f92a1e32bddb655dcaaa85acd397507559cdf11daf98b
+ md5sums = 4860e0f80b53fe62c813beb1dfb04ff2
+ sha256sums = 2e709a751262c83e7b28795da22da63621886ba0567e7712bb163441f7bc5002
+ b2sums = d7186ed9b169df381d15ea21f500a59ea020be010e74877d0802172d50f110884eec4cda2251f9496e4b71dc4273cfb40d9927cfe3a326ca429f8c1307cec171
pkgname = slang-snapshot
diff --git a/PKGBUILD b/PKGBUILD
index d82d1dc04591..30fb68ed096d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,16 @@
pkgname='slang-snapshot'
_pkgname="${pkgname%-snapshot}"
-_pkgver=2.3.4-8
+_pkgver=2.3.4-9
_prever="pre$_pkgver"
pkgver="${_pkgver/-/.}"
-pkgrel=7
+pkgrel=1
pkgdesc='S-Lang is a powerful interpreted language (development snapshot)'
arch=('aarch64' 'armv7h' 'i686' 'x86_64')
provides=('libslang.so' 'slang' 'slsh')
conflicts=('libslang.so' 'slang' 'slsh')
url='https://jedsoft.org/snapshots/'
-license=('GPL-2.0-or-later')
+license=('GPL-2.0-or-later') # SPDX-License-Identifier: GPL-2.0-or-later
depends=(
'glibc'
'libpng'
@@ -25,7 +25,8 @@ options=('lto' '!makeflags')
source=("${url}${_pkgname}-$_prever.tar.gz")
validpgpkeys=('AE962A02D29BFE4A4BB2805FDE401E0D5873000A') # John E. Davis
# Taken from $url
-md5sums=('c740ca7ded82fa29849046ca33c572b1')
+md5sums=('4860e0f80b53fe62c813beb1dfb04ff2')
+changelog="$pkgname.changelog"
build() {
cd "${_pkgname}-${_prever}"
@@ -59,10 +60,10 @@ package() {
# Calculated
sha256sums=(
- 'bd2de566dba919a0cc230b970236c89b095d693cc15344e28f7f9d4e646b9a6b'
+ '2e709a751262c83e7b28795da22da63621886ba0567e7712bb163441f7bc5002'
)
-sha512sums=(
- 'bca104861f947b8a7a318c0cf4128be236eea603f0ca73125d7609d6ff4a7a425d99388e6df64f2d5b1f92a1e32bddb655dcaaa85acd397507559cdf11daf98b'
+b2sums=(
+ 'd7186ed9b169df381d15ea21f500a59ea020be010e74877d0802172d50f110884eec4cda2251f9496e4b71dc4273cfb40d9927cfe3a326ca429f8c1307cec171'
)
# eof
diff --git a/slang-snapshot.changelog b/slang-snapshot.changelog
new file mode 100644
index 000000000000..85cff5e016a4
--- /dev/null
+++ b/slang-snapshot.changelog
@@ -0,0 +1,23 @@
+Changes since 2.3.3
+1. src/slang.c: Use ptrdiff_t instead of long for the intrinsic
+ function prototypes. This is especially important for LLP64
+ systems such as MS windows.
+2. src/slw32tty.c: The console mode was not getting reset by the
+ SLang_reset_tty function on windows systems
+3. src/_slint.h: On windows sytems, use %lld and %llu for long long
+ integer formats
+4. mkfiles/m32init.bat: Copy config file to module and slsh
+ subdirectories (windows-specific)
+5. src/slposio.c: Added a window-specific tweak so that dup2 returns
+ the duped file descriptor. Also updated the regresssion tests
+ (window-specific).
+6. src/slvideo.c: On windows, make calls to SetConsoleScreenBufferSize
+ and SetConsoleWindowInfo after calling CreateConsoleScreenBuffer so
+ that the newly created console will have the correct size. Also
+ INSTALL.pc was updated (windows-specific)
+7. mkfiles/makefile.m32: Added install1 target to work with versions
+ of mingw make that cannot process the install target. Previously
+ this required editing the makefile (windows specific)
+8. src/sltime.c: check for NULL return value from the ctime function
+9. src/slang.ver: Removed the undefined symbol SLang_Rline_Quit,
+ which was causing a link error on Gentoo Linux (Michal Rostecki)