summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhenry0w2020-06-01 17:46:00 -0400
committerhenry0w2020-06-01 17:46:00 -0400
commit1692dd9b2a4332b650afa78ebd7ffd242ec6ed1a (patch)
treed2b89d6af8bd9fb16a264f2647a4ab9cb6ce2842
parentfb08b9fa1f174569fb2f4a723f5df88d080d60d5 (diff)
downloadaur-slate.tar.gz
use release tar, relative links, and quoted file paths
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD53
2 files changed, 33 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f955e3bc79d..e3ab74340f53 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = slate
- pkgdesc = A qt-based pixel art editor
+ pkgdesc = A qt-based purpose-built pixel art editor
pkgver = 0.9.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mitchcurtis/slate
arch = any
license = GPL3
@@ -9,8 +9,8 @@ pkgbase = slate
makedepends = git
depends = qt5-base
depends = qt5-declarative
- source = slate::git+https://github.com/mitchcurtis/slate.git#tag=v0.9.0
- md5sums = SKIP
+ source = https://github.com/mitchcurtis/slate/archive/v0.9.0.tar.gz
+ md5sums = b2726cbb51ff314f5adefc3a891ce228
pkgname = slate
diff --git a/PKGBUILD b/PKGBUILD
index 079701676e40..f89cad427cc7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgname=slate
pkgver=0.9.0
-_pkgname=$pkgname
-pkgrel=1
+_pkgname=$pkgname-$pkgver
+pkgrel=2
epoch=
-pkgdesc="A qt-based pixel art editor"
+pkgdesc="A qt-based purpose-built pixel art editor"
arch=('any')
url="https://github.com/mitchcurtis/slate"
license=('GPL3')
@@ -22,46 +22,51 @@ options=()
install=
changelog=
source=(
- "$_pkgname::git+https://github.com/mitchcurtis/slate.git#tag=v$pkgver"
+ "https://github.com/mitchcurtis/slate/archive/v0.9.0.tar.gz"
)
noextract=()
-md5sums=('SKIP')
+md5sums=('b2726cbb51ff314f5adefc3a891ce228')
validpgpkeys=()
prepare() {
- sed -i "s/Icon=slate/Icon=slate.svg/g" $_pkgname/app/Slate.desktop
- echo "Exec=Slate" >> $_pkgname/app/Slate.desktop
+ sed -i "s/Icon=slate/Icon=slate.svg/g" "$_pkgname/app/Slate.desktop"
+ echo "Exec=slate" >> "$_pkgname/app/Slate.desktop"
+ sed -i "s/TryExec=Slate/TryExec=slate/g" "$_pkgname/app/Slate.desktop"
+ cd $_pkgname
+ git init
}
build() {
- cd $_pkgname
- CPPFLAGS+=" ${CXXFLAGS}"
- cmake -Wno-dev .
+ cd $_pkgname
+ CPPFLAGS+=" ${CXXFLAGS}"
+ cmake -Wno-dev .
cmake --build .
# make -C "${_pkgname}/build" all
}
package() {
- # bin
- install -Dm777 ${_pkgname}/app/app $pkgdir/usr/lib/slate/slate
- mkdir -p $pkgdir/usr/bin
- ln -s $pkgdir/usr/lib/slate/slate $pkgdir/usr/bin/Slate
+ # bin
+ install -Dm777 "${_pkgname}/app/app" "$pkgdir/usr/lib/slate/slate"
+ mkdir -p "$pkgdir/usr/bin"
+
+ ln -sr "$pkgdir/usr/lib/slate/slate" "$pkgdir/usr/bin/slate"
+
# Translations
- for f in $_pkgname/translations/*.ts; do
- install -Dm644 "$f" $pkgdir/usr/lib/slate/
+ for f in "$_pkgname"/translations/*.ts; do
+ install -Dm644 "$f" "$pkgdir/usr/lib/slate/"
done
# Images
- mkdir -p $pkgdir/usr/lib/slate/images
- for f in $_pkgname/app/images/*.png; do
- install -Dm644 "$f" $pkgdir/usr/lib/slate/images/
+ mkdir -p "$pkgdir"/usr/lib/slate/images
+ for f in "$_pkgname"/app/images/*.png; do
+ install -Dm644 "$f" "$pkgdir/usr/lib/slate/images/"
done
- for f in $_pkgname/app/images/*.svg; do
- install -Dm644 "$f" $pkgdir/usr/lib/slate/images/
+ for f in "$_pkgname"/app/images/*.svg; do
+ install -Dm644 "$f" "$pkgdir/usr/lib/slate/images/"
done
# Desktop entry
- install -Dm644 "$_pkgname/app/Slate.desktop" $pkgdir/usr/share/applications/slate.desktop
+ install -Dm644 "$_pkgname/app/Slate.desktop" "$pkgdir/usr/share/applications/slate.desktop"
# Icon
- install -Dm644 "$_pkgname/app/images/logo/slate-icon.svg" $pkgdir/usr/share/icons/slate.svg
+ install -Dm644 "$_pkgname/app/images/logo/slate-icon.svg" "$pkgdir/usr/share/icons/slate.svg"
# License
- install -D -m644 "${_pkgname}/COPYING" -t "${pkgdir}/usr/share/licenses/${_pkgname}"
+ install -D -m644 "${_pkgname}/COPYING" -t "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}