summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhenry0w2020-05-16 18:23:56 -0400
committerhenry0w2020-05-16 18:23:56 -0400
commitfb08b9fa1f174569fb2f4a723f5df88d080d60d5 (patch)
tree32181d9028b20c4b1213af15cad560c29f7e8090
downloadaur-fb08b9fa1f174569fb2f4a723f5df88d080d60d5.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD67
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f955e3bc79d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = slate
+ pkgdesc = A qt-based pixel art editor
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://github.com/mitchcurtis/slate
+ arch = any
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ depends = qt5-base
+ depends = qt5-declarative
+ source = slate::git+https://github.com/mitchcurtis/slate.git#tag=v0.9.0
+ md5sums = SKIP
+
+pkgname = slate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..079701676e40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Henry0w hwelles@protonmail.com
+
+pkgname=slate
+pkgver=0.9.0
+_pkgname=$pkgname
+pkgrel=1
+epoch=
+pkgdesc="A qt-based pixel art editor"
+arch=('any')
+url="https://github.com/mitchcurtis/slate"
+license=('GPL3')
+groups=()
+depends=('qt5-base' 'qt5-declarative')
+makedepends=('cmake' 'git')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(
+ "$_pkgname::git+https://github.com/mitchcurtis/slate.git#tag=v$pkgver"
+)
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+prepare() {
+ sed -i "s/Icon=slate/Icon=slate.svg/g" $_pkgname/app/Slate.desktop
+ echo "Exec=Slate" >> $_pkgname/app/Slate.desktop
+}
+
+build() {
+ cd $_pkgname
+ CPPFLAGS+=" ${CXXFLAGS}"
+ cmake -Wno-dev .
+ cmake --build .
+ # make -C "${_pkgname}/build" all
+}
+package() {
+ # bin
+ install -Dm777 ${_pkgname}/app/app $pkgdir/usr/lib/slate/slate
+ mkdir -p $pkgdir/usr/bin
+ ln -s $pkgdir/usr/lib/slate/slate $pkgdir/usr/bin/Slate
+ # Translations
+ for f in $_pkgname/translations/*.ts; do
+ install -Dm644 "$f" $pkgdir/usr/lib/slate/
+ done
+ # Images
+ mkdir -p $pkgdir/usr/lib/slate/images
+ for f in $_pkgname/app/images/*.png; do
+ install -Dm644 "$f" $pkgdir/usr/lib/slate/images/
+ done
+ for f in $_pkgname/app/images/*.svg; do
+ install -Dm644 "$f" $pkgdir/usr/lib/slate/images/
+ done
+ # Desktop entry
+ install -Dm644 "$_pkgname/app/Slate.desktop" $pkgdir/usr/share/applications/slate.desktop
+ # Icon
+ install -Dm644 "$_pkgname/app/images/logo/slate-icon.svg" $pkgdir/usr/share/icons/slate.svg
+ # License
+ install -D -m644 "${_pkgname}/COPYING" -t "${pkgdir}/usr/share/licenses/${_pkgname}"
+}
+