summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-12 11:49:47 +0800
committerzxp198210052023-12-12 11:49:47 +0800
commitf548dc0f74a2a0ca3b3a099bc3fdcc550ef8e06b (patch)
tree6dc4656550169d6ecad704afe1e83be42831f6be
parent8fcda0013b3a8d67be1efa9eef68d6b2ab35448b (diff)
downloadaur-f548dc0f74a2a0ca3b3a099bc3fdcc550ef8e06b.tar.gz
update to 2.0.3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
-rw-r--r--sleek.sh16
3 files changed, 27 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 840a2e27eedb..77782f1b53ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = sleek-bin
pkgdesc = todo.txt manager for Linux, Windows and MacOS, free and open-source (FOSS)
- pkgver = 2.0.2
+ pkgver = 2.0.3
pkgrel = 1
url = https://github.com/ransome1/sleek
arch = x86_64
license = MIT
- depends = bash
depends = electron25
depends = hicolor-icon-theme
- provides = sleek-2.0.2
+ provides = sleek-2.0.3
conflicts = sleek
- source = sleek-2.0.2.deb::https://github.com/ransome1/sleek/releases/download/v2.0.2/sleek_2.0.2_amd64.deb
- source = LICENSE::https://raw.githubusercontent.com/ransome1/sleek/v2.0.2/LICENSE
+ source = sleek-2.0.3.deb::https://github.com/ransome1/sleek/releases/download/v2.0.3/sleek_2.0.3_amd64.deb
+ source = LICENSE-2.0.3::https://raw.githubusercontent.com/ransome1/sleek/v2.0.3/LICENSE
source = sleek.sh
- sha256sums = 3badb7ac3e706310775197459cfe6a9503917c8a8e1271b652a15d6400bc39c0
+ sha256sums = 36dc6e46477391a1616d541e3d0fe46a9aa736ea38b37e56e096c99bc2ac4787
sha256sums = 3ad193e099728945a4483894e75ce62b0867ce735822f8800afd8d71bf32dad6
- sha256sums = 56720d2369390ede931426873d0b757712d469d0b7393b155b48388f15be14ef
+ sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
pkgname = sleek-bin
diff --git a/PKGBUILD b/PKGBUILD
index 306173476abf..2a77cee8134c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=sleek-bin
-pkgver=2.0.2
+pkgver=2.0.3
+_electronversion=25
pkgrel=1
pkgdesc="todo.txt manager for Linux, Windows and MacOS, free and open-source (FOSS)"
arch=("x86_64")
@@ -9,19 +10,22 @@ license=('MIT')
provides=("${pkgname%-bin}-${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- 'bash'
- 'electron25'
+ "electron${_electronversion}"
'hicolor-icon-theme'
)
source=(
"${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
- "LICENSE::https://raw.githubusercontent.com/ransome1/sleek/v${pkgver}/LICENSE"
+ "LICENSE-${pkgver}::https://raw.githubusercontent.com/ransome1/sleek/v${pkgver}/LICENSE"
"${pkgname%-bin}.sh"
)
-sha256sums=('3badb7ac3e706310775197459cfe6a9503917c8a8e1271b652a15d6400bc39c0'
+sha256sums=('36dc6e46477391a1616d541e3d0fe46a9aa736ea38b37e56e096c99bc2ac4787'
'3ad193e099728945a4483894e75ce62b0867ce735822f8800afd8d71bf32dad6'
- '56720d2369390ede931426873d0b757712d469d0b7393b155b48388f15be14ef')
+ '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
build() {
+ sed -e "s|@electronversion@|${_electronversion}|" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app.asar|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.xz"
sed -e "s|/opt/${pkgname%-bin}/${pkgname%-bin} %U|${pkgname%-bin}|g" \
-e "s|ProjectManagement|Utility|g" \
@@ -36,5 +40,5 @@ package() {
install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
-t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
done
- install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 "${srcdir}/LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
} \ No newline at end of file
diff --git a/sleek.sh b/sleek.sh
index 90f517ec8153..2ec4412e5c4f 100644
--- a/sleek.sh
+++ b/sleek.sh
@@ -1,10 +1,14 @@
#!/bin/bash
-_ELECTRON=/usr/bin/electron25
-APPDIR="/usr/lib/sleek"
-export PATH="${APPDIR}:${PATH}"
-_ASAR="${APPDIR}/app.asar"
+set -e
+_APPDIR="/usr/lib/@appname@"
+export PATH="${_APPDIR}:${PATH}"
+export ELECTRON_IS_DEV=0
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${_APPDIR}/@appasar@"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec ${_ELECTRON} ${_ASAR} "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" "$@"
else
- exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
fi \ No newline at end of file