summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcsculley2019-09-10 01:12:56 -0400
committercsculley2019-09-10 01:12:56 -0400
commit32ee71466ce6f654296f9d019797bccb6bab700f (patch)
tree0f5c9e1994cd5bc67e9a9d0f4e4ec1f7ab400c06
parentdd22c3c392a6e9f0a7ed814a08931d0e542415b0 (diff)
downloadaur-32ee71466ce6f654296f9d019797bccb6bab700f.tar.gz
Fix python script PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e05ea4bc299..2c337b1d793b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sleepplan-git
pkgdesc = Calculate times to wake up based on bedtimes, and vice versa.
pkgver = r19.0389933
- pkgrel = 2
+ pkgrel = 3
url = https://gitlab.com/csculley/sleepplan
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index ff16885fc687..6cd6472600c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christopher Sculley <cs.sculley at gmail dot com>
pkgname=sleepplan-git
pkgver=r19.0389933
-pkgrel=2
+pkgrel=3
pkgdesc="Calculate times to wake up based on bedtimes, and vice versa."
arch=('any')
license=('GPL3')
@@ -21,13 +21,11 @@ pkgver() {
)
}
-build() {
- cd "$pkgname-$pkgver"
- python setup.py build
-}
-
package() {
cd "$pkgname-$pkgver"
- python setup.py install --prefix="/usr" --root="$pkgdir" --optimize=1
+ mkdir -p "$pkgdir"/usr/bin
+ mv sleepplan.py sleepplan
+ chmod +x sleepplan
+ cp sleepplan "$pkgdir"/usr/bin
install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
}