summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcsculley2019-09-10 01:03:03 -0400
committercsculley2019-09-10 01:03:03 -0400
commitdd22c3c392a6e9f0a7ed814a08931d0e542415b0 (patch)
tree663c45401b6db509c6a9b349210884ef171d0953
parent42b0fdb8c61b9b2d60a2962ad9d888d03d9d5894 (diff)
downloadaur-dd22c3c392a6e9f0a7ed814a08931d0e542415b0.tar.gz
Use prefix with setup.py and install license:w
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4769c2d2ea06..6e05ea4bc299 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sleepplan-git
pkgdesc = Calculate times to wake up based on bedtimes, and vice versa.
pkgver = r19.0389933
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/csculley/sleepplan
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index f5bcb57ae62c..ff16885fc687 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christopher Sculley <cs.sculley at gmail dot com>
pkgname=sleepplan-git
pkgver=r19.0389933
-pkgrel=1
+pkgrel=2
pkgdesc="Calculate times to wake up based on bedtimes, and vice versa."
arch=('any')
license=('GPL3')
@@ -21,7 +21,13 @@ pkgver() {
)
}
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
package() {
- cd "$srcdir/$pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ cd "$pkgname-$pkgver"
+ python setup.py install --prefix="/usr" --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
}