summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Lenz2017-01-02 22:08:07 -0600
committerJason Lenz2017-01-02 22:08:07 -0600
commitf84a9435fc53597657bd7fe79193433ddc135c72 (patch)
tree84401a935b18961aa95a9af7120b65fd349a0106
parentcdbe6451b52ff7cce4d057e5e6ccae550a8c2e63 (diff)
downloadaur-f84a9435fc53597657bd7fe79193433ddc135c72.tar.gz
Update to latest commit.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
-rw-r--r--moduleupdates.patch12
3 files changed, 32 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d0563e26edb..e4388207b150 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = sleepyhead-git
pkgdesc = Open-source, cross platform, sleep tracking software with a focus on monitoring CPAP treatment.
- pkgver = 0.9.8.1.ga7a9c4f
- pkgrel = 2
- url = http://sourceforge.net/projects/sleepyhead
+ pkgver = 1.0.0.2.g0e04bd99
+ pkgrel = 1
+ url = http://sleepyhead.jedimark.net
arch = i686
arch = x86_64
license = GPL
@@ -12,8 +12,10 @@ pkgbase = sleepyhead-git
depends = qt5-webkit
depends = glu
conflicts = sleepyhead
- source = git://git.code.sf.net/p/sleepyhead/code
+ source = git+https://gitlab.com/sleepyhead/sleepyhead-code.git
+ source = moduleupdates.patch
sha256sums = SKIP
+ sha256sums = af1390195fc4a5f2aa0cced24b1ce1a629dbd608a40d10dc319cfcbd959bec02
pkgname = sleepyhead-git
diff --git a/PKGBUILD b/PKGBUILD
index 05672506c447..09f627d90681 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Jason Lenz <Jason@Lenzplace.org>
_pkgname=sleepyhead
pkgname=$_pkgname-git
-pkgver=0.9.8.1.ga7a9c4f
-pkgrel=2
+pkgver=1.0.0.2.g0e04bd99
+pkgrel=1
pkgdesc="Open-source, cross platform, sleep tracking software with a focus on monitoring CPAP treatment."
arch=('i686' 'x86_64')
-url="http://sourceforge.net/projects/sleepyhead"
+url="http://sleepyhead.jedimark.net"
license=('GPL')
depends=(
'qt5-base'
@@ -17,14 +17,21 @@ makedepends=('git')
provides=()
conflicts=('sleepyhead')
source=(
- "git://git.code.sf.net/p/sleepyhead/code"
+ "git+https://gitlab.com/sleepyhead/sleepyhead-code.git"
+ 'moduleupdates.patch'
)
sha256sums=(
'SKIP'
+ af1390195fc4a5f2aa0cced24b1ce1a629dbd608a40d10dc319cfcbd959bec02 #moduleupdates.patch
)
+prepare() {
+ cd sleepyhead-code
+ patch -Np1 -i "$srcdir/moduleupdates.patch"
+}
+
pkgver() {
- cd code
+ cd sleepyhead-code
_major=$(sed -rn 's/.*major_version = ([0-9]+).*/\1/p' < sleepyhead/version.h)
_minor=$(sed -rn 's/.*minor_version = ([0-9]+).*/\1/p' < sleepyhead/version.h)
_rev=$(sed -rn 's/.*revision_number = ([0-9]+).*/\1/p' < sleepyhead/version.h)
@@ -34,13 +41,13 @@ pkgver() {
}
build() {
- cd code
+ cd sleepyhead-code
./configure
make
}
package() {
- install -D "$srcdir/code/sleepyhead/SleepyHead" "$pkgdir/usr/bin/SleepyHead"
+ install -D "$srcdir/sleepyhead-code/sleepyhead/SleepyHead" "$pkgdir/usr/bin/SleepyHead"
}
# vim:set ts=2 sw=2 et:
diff --git a/moduleupdates.patch b/moduleupdates.patch
new file mode 100644
index 000000000000..78435431054a
--- /dev/null
+++ b/moduleupdates.patch
@@ -0,0 +1,12 @@
+diff -aur sleepyhead-code/sleepyhead/sleepyhead.pro sleepyhead-code2/sleepyhead/sleepyhead.pro
+--- sleepyhead-code/sleepyhead/sleepyhead.pro 2014-09-27 08:22:20.940889023 -0500
++++ sleepyhead-code2/sleepyhead/sleepyhead.pro 2014-09-27 08:23:12.687558557 -0500
+@@ -7,7 +7,7 @@
+ QT += core gui network xml serialport
+
+ greaterThan(QT_MAJOR_VERSION,4) {
+- QT += widgets webkitwidgets
++ QT += widgets webkitwidgets printsupport
+ } else { # qt4
+ QT += webkit
+ }