summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-03-16 11:35:20 -0500
committerCarlos Aznarán2024-03-16 11:35:20 -0500
commit24cd014106d6934f2743eece26416a11f2c9926a (patch)
tree8d78422ca989aa14f070b0b4c59f0aed80d6a0ab
parenteb0ffd7771206e8ad63cf19310506fa7f9c83aa6 (diff)
downloadaur-24cd014106d6934f2743eece26416a11f2c9926a.tar.gz
Bump version to 3.20.2
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore5
-rw-r--r--.nvchecker.toml5
-rw-r--r--PKGBUILD8
4 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 928b9d70423d..ec252d4ae0c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = slepc
pkgdesc = Scalable library for Eigenvalue problem computations
- pkgver = 3.20.1
- pkgrel = 2
+ pkgver = 3.20.2
+ pkgrel = 1
url = https://slepc.upv.es
install = slepc.install
arch = x86_64
- license = custom:BSD-2-clause
+ license = BSD-2-Clause
makedepends = gcc-fortran
makedepends = cython
depends = petsc>=3.20
provides = slepc4py
options = staticlibs
- source = https://slepc.upv.es/download/distrib/slepc-3.20.1.tar.gz
- md5sums = f052a9a1f7f1378952846bf6375be5bd
+ source = https://slepc.upv.es/download/distrib/slepc-3.20.2.tar.gz
+ md5sums = cbff61d3743a71aa259a3593a51683c4
pkgname = slepc
diff --git a/.gitignore b/.gitignore
index 3f1864bb0ec4..f59ec20aabf5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1 @@
-pkg
-src
-*.tar.gz
-*.tar.xz
+* \ No newline at end of file
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..515cc9cb1964
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,5 @@
+[slepc]
+source = "gitlab"
+gitlab = "slepc/slepc"
+use_max_tag = true
+prefix = "v" \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 0cc65749e409..15280caf6639 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,19 +7,19 @@
# Contributor: Felix Schindler <aur dot felixschindler dot net>
# Contributor: Lucas H. Gabrielli <heitzmann@gmail.com>
pkgname=slepc
-pkgver=3.20.1
-pkgrel=2
+pkgver=3.20.2
+pkgrel=1
pkgdesc="Scalable library for Eigenvalue problem computations"
arch=(x86_64)
url="https://${pkgname}.upv.es"
-license=('custom:BSD-2-clause')
+license=(BSD-2-Clause)
options=(staticlibs)
depends=("petsc>=${pkgver::4}")
makedepends=(gcc-fortran cython)
provides=('slepc4py')
install=${pkgname}.install
source=(${url}/download/distrib/${pkgname}-${pkgver/_/-}.tar.gz)
-md5sums=('f052a9a1f7f1378952846bf6375be5bd')
+md5sums=('cbff61d3743a71aa259a3593a51683c4')
build() {
# get SLEPC_DIR