summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-02-05 19:08:58 +0100
committerMichel Zou2020-02-05 19:08:58 +0100
commit97403f3f57f450fe60adefcaa76da152b9902c62 (patch)
treee77cd69daede3671ee092272f473d099e7c38007
parent85cca74c3cba303279f0982b7bf659265a16da58 (diff)
downloadaur-97403f3f57f450fe60adefcaa76da152b9902c62.tar.gz
Use python3 to configure
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD10
2 files changed, 3 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f6ae1ad6c07..55cce75caf5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = slepc
arch = i686
arch = x86_64
license = BSD
+ makedepends = python
depends = petsc>=3.12
depends = petsc<3.13
source = http://slepc.upv.es/download/distrib/slepc-3.12.2.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 72d5fa29721b..e41b4b16ec81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,6 @@
# Contributor: Myles English <myles at rockhead dot biz>
# Contributor: Lucas H. Gabrielli <heitzmann at gmail dot com>
# Contributor: Hawdaa
-# Contributor: Xantares
pkgname=slepc
pkgver=3.12.2
@@ -14,18 +13,13 @@ arch=('i686' 'x86_64')
url="http://slepc.upv.es"
license=('BSD')
depends=('petsc>=3.12' 'petsc<3.13')
+makedepends=('python')
install=slepc.install
source=(http://slepc.upv.es/download/distrib/${pkgname}-${pkgver/_/-}.tar.gz)
sha256sums=('a586ce572a928ed87f04961850992a9b8e741677397cbaa3fb028323eddf4598')
export MAKEFLAGS="-j1"
-prepare() {
- # force using python2
- find ${srcdir} -name "*" -type f -exec \
- sed -i 's#\(/usr/bin/env \|/usr/bin/\)python[2-3]*#\1python2#' {} \;
-
-}
build() {
# get SLEPC_DIR
@@ -39,7 +33,7 @@ build() {
unset PETSC_ARCH
export SLEPC_DIR=${_build_dir}
- python2 ./configure --prefix=${pkgdir}${_install_dir}
+ python ./configure --prefix=${pkgdir}${_install_dir}
make
}