summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormal2020-02-01 11:46:57 +0000
committermal2020-02-01 11:46:57 +0000
commit72d2ccbc2ca07d832579e19c9a399e81fe5dc5ae (patch)
tree8637dae8a2189fbf67ac90c182ed669a3089ebdb
parent9e1000cb3c332cc2ff381ff622abfb7674a1950c (diff)
downloadaur-72d2ccbc2ca07d832579e19c9a399e81fe5dc5ae.tar.gz
dealt with bad practices
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--download-deps-https.patch13
-rw-r--r--download-ivy-https.patch13
4 files changed, 4 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b569729946a4..d655101e7072 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,12 +13,8 @@ pkgbase = sleuthkit-java
depends = sleuthkit
source = https://github.com/sleuthkit/sleuthkit/releases/download/sleuthkit-4.8.0/sleuthkit-4.8.0.tar.gz
source = build-tmp-dir.patch
- source = download-deps-https.patch
- source = download-ivy-https.patch
- md5sums = b5c081eb2cc92d2e56b8c470de37f890
+ md5sums = c7f9431bceae9b421b337d3c44af4ea9
md5sums = 8a39286ec6585c5298073043af3b4dcf
- md5sums = f951e410ecef03c978d9d2034871fb35
- md5sums = 13c842d0bcc03867548d10e7808e3aa6
pkgname = sleuthkit-java
diff --git a/PKGBUILD b/PKGBUILD
index b1d15fea3826..5d01ce0ea916 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,16 +8,12 @@ url='http://www.sleuthkit.org/sleuthkit'
license=('CPL', 'custom:"IBM Public Licence"', 'GPL2')
depends=(java-environment=8 java8-openjfx sleuthkit)
makedepends=(ant)
-source=("https://github.com/sleuthkit/sleuthkit/releases/download/sleuthkit-${pkgver}/sleuthkit-${pkgver}.tar.gz" "build-tmp-dir.patch" "download-deps-https.patch" "download-ivy-https.patch")
-md5sums=('b5c081eb2cc92d2e56b8c470de37f890'
- '8a39286ec6585c5298073043af3b4dcf'
- 'f951e410ecef03c978d9d2034871fb35'
- '13c842d0bcc03867548d10e7808e3aa6')
+source=("https://github.com/sleuthkit/sleuthkit/releases/download/sleuthkit-${pkgver}/sleuthkit-${pkgver}.tar.gz" "build-tmp-dir.patch")
+md5sums=('c7f9431bceae9b421b337d3c44af4ea9'
+ '8a39286ec6585c5298073043af3b4dcf')
prepare() {
patch "sleuthkit-${pkgver}/bindings/java/build.xml" build-tmp-dir.patch
- patch "sleuthkit-${pkgver}/bindings/java/build.xml" download-ivy-https.patch
- patch "sleuthkit-${pkgver}/bindings/java/ivysettings.xml" download-deps-https.patch
}
build() {
diff --git a/download-deps-https.patch b/download-deps-https.patch
deleted file mode 100644
index 3ccc2ef657e7..000000000000
--- a/download-deps-https.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/ivysettings.xml.old b/ivysettings.xml
-index 29b2bf1..7d58cd2 100644
---- a/ivysettings.xml.old
-+++ b/ivysettings.xml
-@@ -2,7 +2,7 @@
- <settings defaultResolver="default"/>
- <resolvers>
- <chain name="default">
-- <ibiblio name="central" m2compatible="true"/>
-+ <ibiblio name="central" m2compatible="true" root="https://repo1.maven.org/maven2/"/>
- <ibiblio name="ibiblio" m2compatible="true"/>
- </chain>
- </resolvers>
diff --git a/download-ivy-https.patch b/download-ivy-https.patch
deleted file mode 100644
index 86bb36729440..000000000000
--- a/download-ivy-https.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/build.xml.old b/build.xml
-index e959fb4..f11b9d1 100644
---- a/build.xml.old
-+++ b/build.xml
-@@ -105,7 +105,7 @@
-
- <target name="-download-ivy" unless="ivy.available">
- <mkdir dir="${ivy.jar.dir}"/>
-- <get src="http://repo2.maven.org/maven2/org/apache/ivy/ivy/${ivy.install.version}/ivy-${ivy.install.version}.jar" dest="${ivy.jar.file}" usetimestamp="true"/>
-+ <get src="https://repo1.maven.org/maven2/org/apache/ivy/ivy/${ivy.install.version}/ivy-${ivy.install.version}.jar" dest="${ivy.jar.file}" usetimestamp="true"/>
- </target>
-
- <target name="init-ivy" depends="download-ivy" unless="ivy.lib.path">