summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian 'Swift Geek' Grzywna2017-03-01 19:57:48 +0100
committerNick Østergaard2017-03-01 20:24:44 +0100
commit364fae9c71246890adcee4cf8885c1aba99da36d (patch)
treea82ba9c3b592b781aca3f9498a62b034ee505f4c
parent27dede13d26d3685958a90e4d241a178372e6487 (diff)
downloadaur-364fae9c71246890adcee4cf8885c1aba99da36d.tar.gz
Fix use with makepkg -e and -o options
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD26
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 922b56c8ae4b..2955e51efbdb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Mar 1 18:53:57 UTC 2017
+# Wed Mar 1 18:57:48 UTC 2017
pkgbase = slic3r
pkgdesc = Slic3r is an STL-to-GCODE translator for RepRap 3D printers, aiming to be a modern and fast alternative to Skeinforge.
pkgver = 1.2.9
diff --git a/PKGBUILD b/PKGBUILD
index def52482f6b0..0902081fc64d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -44,17 +44,10 @@ md5sums=('05ac7b137cbb7b12f442776e4c12dcc2'
'78f3754e0d3df172a9d48d31ea9afb15'
'316ca184f98c7dca37660f63db16fb6c'
'8853bb4e7e8a5d3debd59a65c4fbbd1c')
+_src_dir='$srcdir/Slic3r-$pkgver'
prepare() {
- export _src_dir="$srcdir/Slic3r-$pkgver"
- # Setting these env variables overwrites any command-line-options we don't want...
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
- export SLIC3R_NO_AUTO="true"
-
- cd "$_src_dir"
+ eval cd "$_src_dir"
# Nasty fix for useless Growl dependency ... please post in comment real fix, if u know one ;)
# sed -i "s/ 'Growl/\#&/" Build.PL
sed -i '/Growl/d' Build.PL
@@ -70,7 +63,14 @@ prepare() {
}
build() {
- cd "$_src_dir/xs"
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+ export SLIC3R_NO_AUTO="true"
+
+ eval cd "$_src_dir/xs"
warning " ⚠ DO NOT respond to any question with 'yes'. Report a bug in comment instead.\n"
warning "Running Slic3r under Perl >= 5.16 is not supported nor recommended\nIn case of related to this issues please use ARM repository to get older perl package\n"
# Cuz cpan will install fixes to $HOME ... which is not the point of this package
@@ -83,7 +83,7 @@ build() {
}
check () {
- cd "$_src_dir"
+ eval cd "$_src_dir"
msg2 "Testing Slic3r::XS - (2/3)"
prove -Ixs/blib/arch -Ixs/blib/lib/ xs/t/
@@ -93,7 +93,7 @@ check () {
}
package () {
- cd "$_src_dir"
+ eval cd "$_src_dir"
install -d $pkgdir/usr/share/perl5/vendor_perl/
cp -R $srcdir/Slic3r-$pkgver/lib/* $pkgdir/usr/share/perl5/vendor_perl/
@@ -117,7 +117,7 @@ package () {
install -m 644 $srcdir/slic3r.desktop $pkgdir/usr/share/applications/
### SLIC3R-XS MERGE
- cd "$_src_dir/xs"
+ eval cd "$_src_dir/xs"
./Build install
# Just to have a more sane bin name also, and automagically fix perl LANG