summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian 'Swift Geek' Grzywna2016-12-20 05:18:50 +0100
committerSebastian 'Swift Geek' Grzywna2016-12-20 05:19:34 +0100
commitb12cbe106928e448dbf1a6dc27c03302f3f0262e (patch)
tree4f47b284d59620df93a0466fa2e26aee4b18fdd0
parentbf5033094f0579b247523b721ea4014dfd3dad4c (diff)
downloadaur-b12cbe106928e448dbf1a6dc27c03302f3f0262e.tar.gz
Remove local::lib use to make it possible to package
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d9f71f47cc25..f9fe547bbbb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
#TODO: integrate with makepkg.d/
pkgname=slic3r-git
-pkgver=a
-pkgrel=16
+pkgver=1.3.0_dev.12165c72
+pkgrel=1
pkgdesc="Slic3r is an STL-to-GCODE translator for RepRap 3D printers, aiming to be a modern and fast alternative to Skeinforge."
arch=('i686' 'x86_64' 'armv6' 'armv6h' 'armv7h')
url="http://slic3r.org/"
@@ -142,6 +142,9 @@ prepare() {
# Nasty fix for useless warning
sed -i '/^warn \"Running Slic3r under Perl/,+1 s/^/\#/' ./lib/Slic3r.pm
+ # Nasty fix for local::lib use
+ find . -iregex '.*\.\(pl\|pm\|t\)' -print0 | xargs -0 -l sed -i -e '/use local::lib/d'
+
# Dependency check - intended of package maintainer only, for now
#TODO: make sure that this if actually works when !check inside makepkg.conf and check inside pkgbuild... find last check and check if it has ! in front?. Is check default?
if [[ " ${BUILDENV[*]} " != *" !check "* ]] || [[ " ${BUILDENV[*]} " == *" !check"*" check "* ]]; then