summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2016-12-21 13:04:21 +0100
committerChristopher Reimer2016-12-21 13:04:21 +0100
commitded63faf1a7dc1cbafd99c031e5e9f7cc6de14c5 (patch)
tree5ee1f11837876974b3825bf411cb2286a0096672
parentc41ae1bafb61d735a740cefcfe20b7936539872d (diff)
downloadaur-ded63faf1a7dc1cbafd99c031e5e9f7cc6de14c5.tar.gz
Add pull request 3575 to fix segfault with perl-opengl version 0.70
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d70658d5fff3..d828f806e03f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname=slic3r
pkgname=${_pkgname}-prusa3d
pkgver=1.31.6
-pkgrel=1
+pkgrel=2
pkgdesc="Updated Slic3r by Prusa3D with many bugfixes and new features"
arch=('i686' 'x86_64' 'armv6' 'armv6h' 'armv7h')
url="http://www.prusa3d.com/"
@@ -25,15 +25,18 @@ provides=('slic3r')
conflicts=('slic3r' 'slic3r-git' 'slic3r-xs' 'slic3r-xs-git')
source=("git+https://github.com/prusa3d/Slic3r.git#tag=version_$pkgver"
"Move-Slic3r-data-to-usr-share-slic3r.patch"
+ "https://patch-diff.githubusercontent.com/raw/alexrj/Slic3r/pull/3575.diff"
'slic3r.desktop')
md5sums=('SKIP'
'03863b8db5dff40e194290ae07d6366f'
+ 'a6933460fdabce17244e7543b09ee692'
'7de264a96d4bcc1143b148ad8d854979')
prepare() {
cd "${srcdir}/Slic3r"
patch -p1 -i "$srcdir/Move-Slic3r-data-to-usr-share-slic3r.patch"
+ patch -p1 -i "$srcdir/3575.diff"
sed -i "s/#define SLIC3R_VERSION .*/#define SLIC3R_VERSION \"$pkgver\"/" xs/src/libslic3r/libslic3r.h
}