summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2018-09-03 19:17:24 +0200
committerChristopher Reimer2018-09-03 19:17:24 +0200
commiteda28ae7584ca7a2298a54896f4085cc44ada819 (patch)
treeeb3a7e3c8072b6beec5231708c4499cdb4524937
parente634a4e8d9e049cc540cdd66f8338ce32c1d3bfd (diff)
downloadaur-eda28ae7584ca7a2298a54896f4085cc44ada819.tar.gz
Update 1.41.0
-rw-r--r--PKGBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06f13c88a01f..6c72a7aba662 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,25 +6,27 @@
_pkgname=slic3r-prusa3d
pkgname=${_pkgname}
-pkgver=1.40.1
-pkgrel=2
+pkgver=1.41.0
+pkgrel=1
pkgdesc="Updated Slic3r by Prusa3D with many bugfixes and new features"
-arch=('i686' 'x86_64' 'armv6' 'armv6h' 'armv7h')
+arch=('i686' 'x86_64')
url="http://www.prusa3d.com/"
license=('AGPL3')
depends=('boost-libs' 'intel-tbb' 'perl' 'perl-class-accessor' 'perl-libwww' 'perl-encode-locale'
'perl-moo' 'perl-opengl' 'perl-sub-quote' 'perl-wx-glcanvas')
-makedepends=('boost' 'cmake' 'git' 'perl-alien-wxwidgets' 'perl-devel-checklib' 'perl-extutils-cppguess'
- 'perl-extutils-typemaps-default' 'perl-module-build-withxspp')
+makedepends=('cmake' 'eigen' 'expat' 'git' 'leatherman' 'perl-alien-wxwidgets' 'perl-devel-checklib' 'perl-extutils-cppguess'
+ 'perl-extutils-typemaps-default' 'perl-module-build-withxspp' 'qhull')
checkdepends=('perl-io-stringy' 'perl-local-lib')
optdepends=('perl-net-dbus: notifications support via any dbus-based notifier'
'perl-net-bonjour: support for autodiscovery of printers on network (octoprint)'
'perl-class-xsaccessor: creating faster accessor methods')
source=("git+https://github.com/prusa3d/Slic3r.git#tag=version_${pkgver}"
"Move-Slic3r-data-to-usr-share-slic3r.patch"
+ "https://raw.githubusercontent.com/PointCloudLibrary/pcl/79c184cc4dbe82d296bb37390064e4a0149234ec/cmake/Modules/FindQhull.cmake"
'slic3r.desktop')
md5sums=('SKIP'
'aceb830f2fbe12ef5659e73164ea733b'
+ '60163025c9bd3d80f2d51a9566f1deab'
'1941c1ede2f03774ffb77f68a7c33572')
prepare() {
@@ -38,17 +40,18 @@ build() {
# Moved this here from prepare(). Because prepare() runs before pkgver() we always set the wrong version.
sed -i "s/define SLIC3R_VERSION .*/define SLIC3R_VERSION \"$pkgver\"/" xs/src/libslic3r/libslic3r.h
-
+
cd build
- cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ cmake -DSLIC3R_STATIC=0 \
+ -DSLIC3R_PROFILE=0 \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
..
+ sed -i "s|$srcdir/Slic3r|../..|g" xs/main.xs
make
}
check() {
- cd "${srcdir}/Slic3r/t" # We're on linux. We don't want to user local::lib
- #sed -i '/local::lib/d' *.t
-
cd "${srcdir}/Slic3r/build"
sed -i 's/\/usr\/bin\/prove/prove/g' CTestTestfile.cmake
sed -i 's/"\/usr\/bin\/perl"//g' CTestTestfile.cmake
@@ -59,6 +62,9 @@ package () {
cd "$srcdir/Slic3r/build"
make DESTDIR="$pkgdir" install
+# mv $pkgdir/usr/lib64/* $pkgdir/usr/lib/
+# rmdir $pkgdir/usr/lib64
+
cd "${srcdir}/Slic3r"
# ZSH autocompletion
@@ -66,9 +72,7 @@ package () {
# Resources
mkdir -p "$pkgdir/usr/share/${_pkgname}"
- cp -R resources/icons "$pkgdir/usr/share/${_pkgname}/"
- cp -R resources/profiles "$pkgdir/usr/share/${_pkgname}/"
- cp -R resources/shaders "$pkgdir/usr/share/${_pkgname}/"
+ cp -R resources/* "$pkgdir/usr/share/${_pkgname}/"
# Desktop file
install -d "$pkgdir/usr/share/applications"