summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-11-25 18:53:50 +0300
committerorhun2020-11-25 18:53:50 +0300
commite4b6856ff96974be50622c13f5472b65415fc264 (patch)
tree5219b82dd6bcb752d5dfb3dc1d6ca297f2b9f2c1
parentad9451ebe4bebda286cb4f914e88cc704bb6597a (diff)
downloadaur-e4b6856ff96974be50622c13f5472b65415fc264.tar.gz
upgpkg: slicer-git 1.4.r5.gb70e33f-1
Respect go flags for PIE and RELRO
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6e299753ebc..f9b40b3bad5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = slicer-git
pkgdesc = A tool to automate the boring process of APK recon (git)
- pkgver = 1.4.r0.g50589ac
- pkgrel = 2
+ pkgver = 1.4.r5.gb70e33f
+ pkgrel = 1
url = https://github.com/mzfr/slicer
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 26c5c4a48874..376a79414df5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=slicer-git
pkgdesc="A tool to automate the boring process of APK recon (git)"
-pkgver=1.4.r0.g50589ac
-pkgrel=2
+pkgver=1.4.r5.gb70e33f
+pkgrel=1
arch=('x86_64')
url="https://github.com/mzfr/slicer"
license=('GPL3')
@@ -21,12 +21,12 @@ pkgver() {
build() {
cd "${pkgname%-git}"
- go get -d ./...
- go build \
- -gcflags "all=-trimpath=$PWD" \
- -asmflags "all=-trimpath=$PWD" \
- -ldflags "-extldflags $LDFLAGS" \
- -o "${pkgname%-git}" .
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o "${pkgname%-git}" .
}
package() {